make deb-inplace gives error

Installation related questions should be posted here.
JoePass
Kitten
Kitten
Posts: 11
Joined: Wed Nov 16, 2016 6:54 pm

make deb-inplace gives error

Postby JoePass » Wed Nov 16, 2016 8:26 pm

I'm new user of fvwm and try to install in VM fvwm-2.6.7. I use mini.iso for ubuntu 16.04. Install only core, next xserver-xorg (with next Xorg -configure) and xinit. Then all packages to install fvwm from https://help.ubuntu.com/community/FVWM. Then I download fvwm-2.6.7, unpack and then configure by ./configure (or ./configure --prefix=/usr). Makefile appears and no error during compilation except librsvg, libstroke, librplay but these are not important. But when I execute make deb-inplace I obtain: make: *** No rules for make "deb-inplace" Stop (This is translation from Russian). I do not understand what happen. Could you help me?

somiaj
Administrator
Administrator
Posts: 46
Joined: Mon Nov 08, 2004 9:54 pm
Location: Idaho (USA)
Contact:

Re: make deb-inplace gives error

Postby somiaj » Thu Nov 17, 2016 3:14 am

As per the NEWS file of changes in 2.6.7

The old and unmaintained debian/and rpm/ directories have been remmoved;


Part of this is removing the 'deb-inplace' build target (since there is no debian/ for it). You won't be able to build a .deb directly with the source using the deb-inplace target. In order to build a .deb you will have to create your own debian/ dir, and maybe debian-helper (dh_make) can do this.

I am unsure how well this will work in Ubuntu, but I have been in the process of building a package for Debian. Thus I have a newer debian/ dir set up to build a package for Debian policy.

You can find everything that I have done at the link

http://fvwmforums.org/fvwm-2.6.7/

You can get a copy of the source package, the debian/ (fvwm_debian.tar.gz) used, and even the actual source package for fvwm-2.6.7 from this setup. I also have an amd64.deb made, but this was made on Debian Stretch and there is no guarantee how well it will work on your Ubuntu setup (usually I advise building your own packages in this case).

The other option is just run 'make install' and this should install fvwm in /usr/local which if Ubuntu follows some of the same FHS standards as Debian not get in the way of your Ubuntu packages.

jaimos
-jaimos

JoePass
Kitten
Kitten
Posts: 11
Joined: Wed Nov 16, 2016 6:54 pm

Re: make deb-inplace gives error

Postby JoePass » Fri Nov 18, 2016 8:53 pm

Thank you for reply. I made make and make install. It was much easy then make deb.

phleagol
Cat in the hat
Cat in the hat
Posts: 40
Joined: Sun Nov 24, 2013 1:19 pm
Location: New Zealand

Re: make deb-inplace gives error

Postby phleagol » Sat Nov 19, 2016 4:43 am

Thank you, Jaimos. Until now, I have been using the checkinstall method. But your way looks more proper. It worked for me with these steps...

Code: Select all

sudo apt-get build-dep fvwm
wget http://fvwmforums.org/fvwm-2.6.7/fvwm_2.6.7.orig.tar.gz
wget http://fvwmforums.org/fvwm-2.6.7/fvwm_2.6.7-1.debian.tar.xz
tar -xf fvwm_2.6.7.orig.tar.gz
cd fvwm-2.6.7
tar -xf ../fvwm_2.6.7-1.debian.tar.xz
debchange --local daggoth
time dpkg-buildpackage -us -uc

somiaj
Administrator
Administrator
Posts: 46
Joined: Mon Nov 08, 2004 9:54 pm
Location: Idaho (USA)
Contact:

Re: make deb-inplace gives error

Postby somiaj » Sun Nov 20, 2016 4:33 am

phleagol wrote:Thank you, Jaimos. Until now, I have been using the checkinstall method. But your way looks more proper. It worked for me with these steps...


Glad it worked. Enjoy! I hope to get the package into Debian but this works for now.
-jaimos


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest