WarpToWindow broken?

Problems with decorations or key/mouse bindings? Or perhaps you have a cool mouse/key binding you want to share.
jbazik
Kitten
Kitten
Posts: 5
Joined: Fri Jul 01, 2011 5:34 pm

WarpToWindow broken?

Postby jbazik » Fri Jul 01, 2011 6:07 pm

Hi. I've used the following keybindings (among others) since the last century. Today I upgraded from 2.5.26 to 2.5.30 (Debian Lenny to Squeeze), and WarpToWindow no longer works as it did before.

Code: Select all

Key h   A       M       CursorMove      -10     0
Key j   A       M       CursorMove      0       10
Key k   A       M       CursorMove      0       -10
Key l   A       M       CursorMove      10      0
key s   A       M       WindowId root 0 WarpToWindow 50 50
key d   A       M       WindowId root 1 WarpToWindow 50 50


I have two monitors, configured as two screens, and when I warp from one to the other, things are fine unless I land on the root window. In that case, the focus remains on the screen that I came from. In particular, when I try to use the "vi" keys (defined above) to move around, I can't until I grab the mouse and click. If I land on a window, all is well.

Perhaps I'm doing something sketchy there? Or did I find a bug?

thomasadam
Administrator
Administrator
Posts: 3043
Joined: Mon Nov 08, 2004 1:12 am
Location: England
Contact:

Re: WarpToWindow broken?

Postby thomasadam » Sat Jul 02, 2011 6:09 pm

jbazik wrote:Hi. I've used the following keybindings (among others) since the last century. Today I upgraded from 2.5.26 to 2.5.30 (Debian Lenny to Squeeze), and WarpToWindow no longer works as it did before.


Use FVWM 2.6.1.

jbazik wrote:I have two monitors, configured as two screens, and when I warp from one to the other, things are fine unless I land on the root window. In that case, the focus remains on the screen that I came from. In particular, when I try to use the "vi" keys (defined above) to move around, I can't until I grab the mouse and click. If I land on a window, all is well.

Perhaps I'm doing something sketchy there? Or did I find a bug?


It is working just as it should in the case of sloppyfocus where the very notion of the pointer in the root window means the focus is still kept on the last-focused window, regardless of the screen the pointer is on.

You'll need to be more specific about what you think isn't working, but so far, there's no bug that I can see.

-- Thomas Adam

jbazik
Kitten
Kitten
Posts: 5
Joined: Fri Jul 01, 2011 5:34 pm

Re: WarpToWindow broken?

Postby jbazik » Tue Jul 05, 2011 4:07 pm

thomasadam wrote:It is working just as it should in the case of sloppyfocus where the very notion of the pointer in the root window means the focus is still kept on the last-focused window, regardless of the screen the pointer is on.

I don't have SloppyFocus set. I use the default, MouseFocus. When I move the mouse from a window to the root, the focus follows. It only does not in the case I mentioned - when I warp from one screen to the other, and land on the root.

In fact, when I warp from one root to the other, the focus remains with whichever one had it last. If I move the mouse from one root to the other (without crossing any windows) then the focus follows the mouse.

thomasadam
Administrator
Administrator
Posts: 3043
Joined: Mon Nov 08, 2004 1:12 am
Location: England
Contact:

Re: WarpToWindow broken?

Postby thomasadam » Tue Jul 05, 2011 9:56 pm

I still can't reproduce this.

I'm using Xinerama. I use your keybindings. I also use MouseFocus.

If I am on a window and warptowindow and land on the root window, regardless of the screen, the window the mouse was on previously loses focus.

Or when you say you're using two screens, do you mean * INDEPENDENT* screens? Only that sort of detail *is* important.

-- Thomas Adam

jbazik
Kitten
Kitten
Posts: 5
Joined: Fri Jul 01, 2011 5:34 pm

Re: WarpToWindow broken?

Postby jbazik » Wed Jul 06, 2011 5:36 am

thomasadam wrote:Or when you say you're using two screens, do you mean * INDEPENDENT* screens? Only that sort of detail *is* important.

Yes, I have two independent screens, no xinerama or twinview. I prefer to mix and match separate workspaces. I've been using this config for many years, through many upgrades and I've never had an issue until now.

Whether or not it's a bug, I'd really appreciate any suggestions for a workaround. I spent some time playing with my config, but I wasn't able to produce the old behavior.

Thanks for taking the time to look at this.

thomasadam
Administrator
Administrator
Posts: 3043
Joined: Mon Nov 08, 2004 1:12 am
Location: England
Contact:

Re: WarpToWindow broken?

Postby thomasadam » Fri Jul 08, 2011 10:28 pm

jbazik wrote:
thomasadam wrote:Or when you say you're using two screens, do you mean * INDEPENDENT* screens? Only that sort of detail *is* important.

Yes, I have two independent screens, no xinerama or twinview. I prefer to mix and match separate workspaces. I've been using this config for many years, through many upgrades and I've never had an issue until now.

Whether or not it's a bug, I'd really appreciate any suggestions for a workaround. I spent some time playing with my config, but I wasn't able to produce the old behavior.

Thanks for taking the time to look at this.


No worries.

Can you give me instructions as to how you've configured X and FVWM to run in the environment you're using?

Thanks.

-- Thomas Adam

jbazik
Kitten
Kitten
Posts: 5
Joined: Fri Jul 01, 2011 5:34 pm

Re: WarpToWindow broken?

Postby jbazik » Mon Jul 11, 2011 11:43 pm

thomasadam wrote:Can you give me instructions as to how you've configured X and FVWM to run in the environment you're using?


Sure, here are my xorg.conf and an edited (and tested) .fvwmrc. I removed the personal bits and extraneous junk from the fvwm config, but made sure it still exhibits the same focus behavior.

http://cs.brown.edu/~jsb/fvwm/xorg.conf
http://cs.brown.edu/~jsb/fvwm/fvwmrc

John

jbazik
Kitten
Kitten
Posts: 5
Joined: Fri Jul 01, 2011 5:34 pm

Re: WarpToWindow broken?

Postby jbazik » Tue Aug 02, 2011 4:21 pm

Thomas, any further thoughts about this?

John

thomasadam
Administrator
Administrator
Posts: 3043
Joined: Mon Nov 08, 2004 1:12 am
Location: England
Contact:

Re: WarpToWindow broken?

Postby thomasadam » Tue Aug 02, 2011 5:23 pm

jbazik wrote:Thomas, any further thoughts about this?

John


I've not had time to look in to it yet.

-- Thomas Adam


Return to “Decorations and bindings”

Who is online

Users browsing this forum: No registered users and 1 guest