xterm icons

All questions regarding FVWM that don't fit anywhere else.
mzp3769
Kitten
Kitten
Posts: 2
Joined: Sun Nov 16, 2014 3:05 am

xterm icons

Postby mzp3769 » Sun Nov 16, 2014 3:17 am

I recently upgraded to fvwm 2.6.5 from Macports. When I iconize xterm in addition to the title I also get mini xterm picture. That is inconvenient since takes space, especially if you work with multiple windows. How to prevent this behavior and just have icon name. My entry in .fvwm2rc
is

Style "XTerm" IconBox 100x1000-10+400, \
IconGrid 25 40, IconFill right top \


Thanks,
Mark

User avatar
TF
Moderator
Moderator
Posts: 246
Joined: Sat Sep 10, 2005 12:30 am
Location: Germany
Contact:

Re: xterm icons

Postby TF » Mon Nov 17, 2014 12:00 am

mzp3769 wrote:... When I iconize xterm in addition to the title I also get mini xterm picture. That is inconvenient since takes space, especially if you work with multiple windows. How to prevent this behavior and just have icon name.
Add

Code: Select all

Style "XTerm" Icon 123.xpm
to point to a non existing icon file.

-- Thomas --
"Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe." -- Albert Einstein
Fvwm version: 2.6.5
Fvwm config: Fvwm-Nightshade

mzp3769
Kitten
Kitten
Posts: 2
Joined: Sun Nov 16, 2014 3:05 am

Re: xterm icons

Postby mzp3769 » Mon Nov 17, 2014 4:02 am

TF wrote:
mzp3769 wrote:... When I iconize xterm in addition to the title I also get mini xterm picture. That is inconvenient since takes space, especially if you work with multiple windows. How to prevent this behavior and just have icon name.
Add

Code: Select all

Style "XTerm" Icon 123.xpm
to point to a non existing icon file.

-- Thomas --

This did not help, still getting little image of xterm above the icon name,
Mark

User avatar
theBlackDragon
Administrator
Administrator
Posts: 714
Joined: Wed Oct 27, 2004 9:22 pm
Location: Zingem, Belgium
Contact:

Re: xterm icons

Postby theBlackDragon » Mon Nov 17, 2014 6:39 pm

mzp3769 wrote:
TF wrote:
mzp3769 wrote:... When I iconize xterm in addition to the title I also get mini xterm picture. That is inconvenient since takes space, especially if you work with multiple windows. How to prevent this behavior and just have icon name.
Add

Code: Select all

Style "XTerm" Icon 123.xpm
to point to a non existing icon file.

-- Thomas --

This did not help, still getting little image of xterm above the icon name,
Mark


You might need to add IconOverride otherwise the Icon style should not override the default set by the application.

User avatar
ILLUXA
Cat in the hat
Cat in the hat
Posts: 25
Joined: Sat May 28, 2016 4:07 pm
Location: $[HOME]

Re: xterm icons

Postby ILLUXA » Wed Aug 23, 2017 2:53 pm

Also it is possible to disable XTerm active mini icons,
Image
with "--disable-active-icon" flag, while rebuilding XTerm:

Code: Select all

% fetch http://invisible-island.net/datafiles/release/xterm.tar.gz
% tar xvf xterm.tar.gz && cd xterm-330/
% ./configure --disable-active-icon
# make && make install

Image
Transcend or Die

FVWM 2.6.7, FreeBSD 11.1-RELEASE

thomasadam
Administrator
Administrator
Posts: 3043
Joined: Mon Nov 08, 2004 1:12 am
Location: England
Contact:

Re: xterm icons

Postby thomasadam » Wed Aug 23, 2017 2:56 pm

ILLUXA wrote:Also it is possible to disable XTerm active mini icons,


You can do the same thing with just:

Code: Select all

xterm -ai


No need to go about compiling xterm for something you can control at run time!

-- Thomas Adam

User avatar
ILLUXA
Cat in the hat
Cat in the hat
Posts: 25
Joined: Sat May 28, 2016 4:07 pm
Location: $[HOME]

Re: xterm icons

Postby ILLUXA » Wed Aug 23, 2017 3:58 pm

On FreeBSD, it is very easy to change any build options because of ports tree,
it takes only few seconds to add or remove some configure flags via Makefile,
in result you don't need to add any additional flags to xterm, so it is more preferable way for me.


P.S.: Please, disable image resolution limit! It is very annoying! FVWM is such a nice window manager, so screenshots on forum pages would look beautifully!

P.P.S.: It is also possible to disable xterm active icons via ~/.Xdefaults:

Code: Select all

XTerm*activeIcon:         false
Transcend or Die

FVWM 2.6.7, FreeBSD 11.1-RELEASE


Return to “General questions”

Who is online

Users browsing this forum: No registered users and 1 guest