FvwmIconMan swallowed by FvwmButtons

All questions regarding FVWM that don't fit anywhere else.
geterdone
Kitten
Kitten
Posts: 16
Joined: Sun Jan 08, 2012 6:34 am

FvwmIconMan swallowed by FvwmButtons

Postby geterdone » Sat Mar 01, 2014 6:19 pm

Hi:

I have FvwmIconMan which is swallowed by FvwmButtons, and find that every now and then the IconMan seems to "disappear" from the FvwmButton, meaning the button that swallowed FvwmIconMan is just empty. I can see that the IconMan is still running (via 'top' say), but it just doesn't show up. Restarting Fvwm "fixes" the problem. I run Fvwm on 3 different computers, and this seems to happen say once every couple of weeks, but the logs don't show anything obvious and I have been unable to pin point what's going on. Here is the relevant configs:

Code: Select all

DestroyFunc StartFunction
AddToFunc StartFunction
+ I Module FvwmIconMan AppIconMan
+ I Module FvwmButtons ButtonsTopBar

Style AppIconMan !Title, Sticky, StaysOnTop, WindowListSkip, StaysOnTop, NeverFocus, !Icon ,!Handles, !Borders

DestroyModuleConfig AppIconMan: *

*AppIconMan: Colorset 111
*AppIconMan: FocusColorset 112
*AppIconMan: FocusAndSelectColorset 112
*AppIconMan: IconColorset 102
*AppIconMan: Resolution Page
*AppIconMan: UseWinList True
*AppIconMan: ShowNoIcons False
*AppIconMan: ShowTransient False
*AppIconMan: DrawIcons Always
*AppIconMan: Sort none
*AppIconMan: Title ""
*AppIconMan: ButtonGeometry 1x1
*AppIconMan: ManagerGeometry 1x1
*AppIconMan: MaxButtonWidthByColumns 1
*AppIconMan: Font "xft:sans:pixelsize=11"
*AppIconMan: ReliefThickness 0
*AppIconMan: Tips needed
*AppIconMan: TipsFormat "%i"
*AppIconMan: TipsDelays 500 200
*AppIconMan: TipsFont "xft:Verdana:pixelsize=11"
*AppIconMan: TipsBorderWidth 1
*AppIconMan: TipsColorset 101
*AppIconMan: TipsJustification leftup
*AppIconMan: TipsPlacement right

*AppIconMan: Action Mouse 0 N sendcommand Nop
*AppIconMan: Action Mouse 1 N SendCommand FocusAndRaise
*AppIconMan: Action Mouse 2 N SendCommand Close
*AppIconMan: Action Mouse 3 N SendCommand "Popup Window-Ops mouse c +0+9p"

DestroyModuleConfig ButtonsTopBar: *

*ButtonsTopBar: Colorset 110
*ButtonsTopBar: ActiveColorset 113
*ButtonsTopBar: Font "xft:sans:pixelsize=11"
*ButtonsTopBar: Columns $[vp.width]
*ButtonsTopBar: Rows 1
*ButtonsTopBar: Back white
*ButtonsTopBar: Frame 0
*ButtonsTopBar: Padding 2 0
*ButtonsTopBar: Geometry $[vp.width]x$[FVWM_BASE_STRUTS_TOP]+0+0

*ButtonsTopBar: ($[FVWM_BUTTONS_WIDTH_ICONMAN]x1, Swallow (SwallowNew) AppIconMan)



Here is the fvwm version i am using:
fvwm 2.6.5 compiled on Dec 13 2013 at 02:22:22
with support for: ReadLine, RPlay, Stroke, XPM, PNG, SVG, Shape, XShm, SM, Bidi text, Xinerama, XRender, XCursor, XFT, NLS

Has anyone else experienced this?

thanks

Return to “General questions”

Who is online

Users browsing this forum: No registered users and 1 guest