Copied over ~/.fvwm* to desktop, got right menus and stuff..

But I still have the default window borders. The differences between these 2 machines is that one is running Gentoo and the other Fedora Core 6, I am rather new to Fedora so I have no clue what’s different and why my config won’t work, maybe different versions? Any ideas? I can post my ~/.fvwm2rc’s if needed.

You get default window borders, because that’s what’s specified in $(fvwm-config -d)/ConfigFvwmDefaults. FVWM reads this file before it does any other file, which is why one typically overrides such style settings in their ~/.fvwm2rc file.

I suspect what’s happening is that your FC machine is running FVWM 2.4.X which might explain a lot. Of course, without more pertinent details from you as to what is actually wrong, I can’t be anymore specific than that. Although you should read the following:

– Thomas Adam

grr more woes as I try to update fvwm, I need but I have :S

That’s just a symlink issue. Symlink to and run:

ldconfig -X

as root.

– Thomas Adam

That’s what my friend suggested, minus the ldconfig -X part, figured that might help, still no go after symlinking to and to I still get failed deps on libpng and libxft. hrm, can’t seem to find out how to get them besides updating xorg, might give that a shot soon

Depends whether they’re in /usr/local/lib and if that directory exists in /etc/ before running the ldconfig command.

Either way, it’s not the best approach, and you should really look at the output of:

ldd $(which fvwm)

To see what else is amiss. This seems like typical Fedora to me.

– Thomas Adam

Yea, the rest of Fedora is so nice and clean though, as soon as I try to get fvwm working it gets a little messy, sometimes that’s the best part but if you don’t see any progress sometimes you just have to vent your frustration somehow hehe. anywho here’s the output of ldd ($which fvwm)

# ldd $(which fvwm) => (0x00cba000) => /usr/lib/ (0x0050a000) => /usr/lib/ (0x004b8000) => /usr/lib/ (0x006f6000) => /usr/lib/ (0x00693000) => /usr/lib/ (0x004a6000) => /usr/lib/ (0x00a06000) => /lib/ (0x008fe000) => /lib/ (0x007bf000) => /usr/lib/ (0x00b12000) => /usr/lib/ (0x00b0a000) => /lib/ (0x00927000) /lib/ (0x007a2000)

Well, that doesn’t show FVWM as having XFT compiled in. What does:

fvwm -V


If you’re compiling this yourself, you will need the libxft development package installed (that’s the header files).

– Thomas Adam

I’m using prebuilt binaries from
Current installed version of fvwm is 2.4.19 on my fedora box, 2.5.18 on my gentoo box which could explain the lack of compatibility, which is why I’m hopefull that getting to a 2.5.x fvwm will help fix this issue.