find .fvwm2rc under Suse 9.0


I’m using SUSE Linux 9.0 and I want to try out the fvwm2 X-Server but I have trouble to find the .fvvwm2rc…
In my Home directory is a .wmrc but this file only has one entry: “fvwm2”.
I tried the “find” command to find the .fvwm2rc but I doesne’t find it.
Is it possibe that the configuration file has a other name?



First off, Fvwm is no X-Server, but a Window Manager.

No that that’s cleared up, on to the real issue :wink:

First off, have you already tried starting Fvwm? If so you should have gotten some ugly screen much like this. When you click (or middle click) on the background you should get a menu that allows you to choose from one of the default configurations available.

The above is the quickest way to start off, now there are two other ways to go, which one you prefer is up to you of course…

  1. You can write your configuration totally from scratch using for example the guides mentioned in this thread.
  2. You could use somebody else’s configuration file and modify that, there are numerous sites that list configurations you can borrow, not in the least itself, but my site also lists a couple of the most popular configurations that people base their own on.

Independent of the way you choose to go I recommend you have a look at the Fvwm beginner’s guide.

I hope this provides some helpful information to you :slight_smile:

oh, sure…not a X-server…okay I will remeber this!

Yes, I already started fvwm2. In the moment, I use it!
Therefor I think there should already be an configuration file, or can I run and use fvwm2 without an config-file?

I will try it with your tips! Thanks for the help!



P.s.: Excuse my englisch, it’s not very well…at the moment…

It may be that fvwm uses the system’s configuration file, though I wouldn’t know where that one would be located.

By default Fvwm’s configuration file (as of version 2) is in a folder called ~/.fvwm in that folder there should be a file called .fvwm2rc (all 2.x versions) or just plain config (as of version 2.5.10 iirc).

As for your English: I think it’s okay :slight_smile:

I found the file, I think. in /etc/X11/fvwm2 is a file called system.fvwm2rc.
It looks like the configuration file I was looking for. I will try to copy it to my home directory and make some changes…

Thanks again for help

edit:/ Yes, that was the correct file!!