Invisible Window

Hi All,

I’m looking for a way to make my FvwmButtons panel invisible (and then visible if needed).
I tried to do it with a Layer command but no luck.

Any suggestion is very appreciated.

Thanks a lot in advance

Best regards


Invisible in what way? As it’s FvwmButtons you have some options:

  1. Panelise it. That is, make it retractable with a little button that makes it popup again. (See ‘Man FvwmButtons’ for more information.

  2. You can autohide it. See:

  1. Or you can do what I do with EdgeCommand and a NoIcon style, hence:
Style myFvwmButtonsName NoIcon

Which means that when it is minimised I won’t see it in the root desktop. As for hiding/unhiding it, I do so by triggering an event that happens when my mouse hits the bottom of the screen, as in:

EdgeCommand Bottom All (myFvwmButtonsName) Iconify
  1. You can use a key-combination to move it to a non-visible part of your desk, as in something like this:

Key Q A CS All (myFvwmButtonsName) AnimatedMove -5000 -5000

(Yes, the location is exaggerated, and yes I realise that’s not a toggling action, but search these forums for ‘toggling’ and that will yield some answers.)

  1. You could make the FvwmButtons transient. That is, it’s only ever visible until it receives a click, and the it is closed. That’s a command-line flag at invocation time. Again, see ‘man FvwmButtons’.

Is that enough ways?

– Thomas Adam

Hi Thomas,

Thanks a lot for Your suggestions.
It is more then enough ways :slight_smile:

I did it with NoIcon style-options and Iconify-command, it works fine.

I decided to do it on this way, because I’m traying to make a fvwm-config for my Linux PDA (Sharp Zaurus) and prefer to work with the keyboard not with the touch-screen.

Another possibilities are very interesting as well, especially when I will make the config for PDA-Mode (keyboard can not be used, only the touch-screen).

Best regards