make deb-inplace gives error

I’m new user of fvwm and try to install in VM fvwm-2.6.7. I use mini.iso for ubuntu 16.04. Install only core, next xserver-xorg (with next Xorg -configure) and xinit. Then all packages to install fvwm from Then I download fvwm-2.6.7, unpack and then configure by ./configure (or ./configure --prefix=/usr). Makefile appears and no error during compilation except librsvg, libstroke, librplay but these are not important. But when I execute make deb-inplace I obtain: make: *** No rules for make “deb-inplace” Stop (This is translation from Russian). I do not understand what happen. Could you help me?

As per the NEWS file of changes in 2.6.7

Part of this is removing the ‘deb-inplace’ build target (since there is no debian/ for it). You won’t be able to build a .deb directly with the source using the deb-inplace target. In order to build a .deb you will have to create your own debian/ dir, and maybe debian-helper (dh_make) can do this.

I am unsure how well this will work in Ubuntu, but I have been in the process of building a package for Debian. Thus I have a newer debian/ dir set up to build a package for Debian policy.

You can find everything that I have done at the link

You can get a copy of the source package, the debian/ (fvwm_debian.tar.gz) used, and even the actual source package for fvwm-2.6.7 from this setup. I also have an amd64.deb made, but this was made on Debian Stretch and there is no guarantee how well it will work on your Ubuntu setup (usually I advise building your own packages in this case).

The other option is just run ‘make install’ and this should install fvwm in /usr/local which if Ubuntu follows some of the same FHS standards as Debian not get in the way of your Ubuntu packages.


Thank you for reply. I made make and make install. It was much easy then make deb.

Thank you, Jaimos. Until now, I have been using the checkinstall method. But your way looks more proper. It worked for me with these steps…

sudo apt-get build-dep fvwm wget wget tar -xf fvwm_2.6.7.orig.tar.gz cd fvwm-2.6.7 tar -xf ../fvwm_2.6.7-1.debian.tar.xz debchange --local daggoth time dpkg-buildpackage -us -uc

Glad it worked. Enjoy! I hope to get the package into Debian but this works for now.