MultiDesk, Rocket, gravity and Window priority problem

I all,

I’m making and application who have to work on fvwm and on other linux environnement.

I’ve got several problem using Fvwm :

  • I want to disable gravity / geometry attraction for all my windows. I know that it’s possible using FvwmCommand but i want that the gravity is alway remove for all my windows. Some windows are moved by my program and it creates me problems because of the gravity.

  • I want to suppress the virtual desktop. I’ve got a 2 screen configuration : A master screen and an auxiliary screen. When I move a window to the border of a screen, the contents of the others windowa disapear.

  • I’ve got a micture of a rocket in the bottom right corner of my window when i resize my window. How can I suppress it.

  • I’ve got a priority problem : I’ve configure the priority of my window, but when I click on a less priority window, the others windows are hidden.

Thanks for the futur help

Are you sure of this? Before you disable it, I suggest you add:

BugOpts ExplainWindowPlacement

To your fvwm2rc file, and assuming fvwm logs to ~/.xsession-errors, see what it says when it places your window.

You can tell Fvwm to ignore the gravity bit, by using:

Style foo IgnoreGravity
DesktopSixe 1x1

I don’t know what you’re talking about there – it’s a facet of your conguration, probably. Can you see your config, and/or a screenshot of this?

Really? What do you mean by “priority” in this case? Can you be more specific?

– Thomas Adam

Just do make sure I’m clear on the problem: do you have a two desk setup, with possible multiple pages within those desks, or do you have a single desk with two pages?

If you have two desks, then your vanishing windows are probably due to the desktop auto-scrolling onto an adjacent page.

You can specify the number of pages per desk with DeskTopSize. Or you can disable auto-scrolling with

EdgeScroll 0 0

Thanks for your help.

I’ve try to modify fvwm2rc configuration file, but I don’t have one on my computer. May be because I have install theme management.

Here is the contain of my hard drive for file named fvwm2rc :

/usr/share/fvwm/system.fvwm2rc-sample-95 /usr/local/share/fvwm/system.fvwm2rc-sample-95 /usr/local/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-1 /usr/local/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-95 /usr/local/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc /usr/local/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-2 /usr/local/fvwm-2.5.12/modules/FvwmConsole/.fvwm2rc.sample /usr/local/fvwm-2.5.12/modules/FvwmSaveDesk/example/fvwm2rc /usr/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-1 /usr/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-95 /usr/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc /usr/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-2 /usr/fvwm-2.5.12/modules/FvwmConsole/.fvwm2rc.sample /usr/fvwm-2.5.12/modules/FvwmSaveDesk/example/fvwm2rc /home/asduser/Config/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-1 /home/asduser/Config/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-95 /home/asduser/Config/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc /home/asduser/Config/fvwm-2.5.12/sample.fvwmrc/system.fvwm2rc-sample-2 /home/asduser/Config/fvwm-2.5.12/modules/FvwmConsole/.fvwm2rc.sample /home/asduser/Config/fvwm-2.5.12/modules/FvwmSaveDesk/example/fvwm2rc

I’ve try to update the file ]/usr/share/fvwm/system.fvwm2rc-sample-95 and put the option :

Style foo IgnoreGravity

but nothing happened.

Which file might I modify?

If i have a look to the .xsessions-error file, this happened :

access control disabled, clients can connect from any host
[FVWM-Themes]: Starting FVWM under the main fvwm-themes session
[FVWM][__execute_function]: <<ERROR>> No such command 'This'
_cdim: --- not moved 0x081845e0 'nohup asd-viewer-0.1.1.1&'
_cdim: --- not moved 0x081845e0 'nohup asd-viewer-0.1.1.1&'
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
s 371/-30 -136/-30, g 375/  1 -132/ 1: --- not detected 0x08183a60 'Main Radar'
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
s 367/-30 -4/ 0, g 371/  1  0/31: --- not detected 0x08183a60 'Main Radar'
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
...
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
s  -3/-30  0/ 0, g   1/  1  4/31: +++ travelling traditional 0x08183a60 'Main Radar'
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'

...
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
s  -3/334 165/-31, g   1/365 169/ 0: --- not detected 0x081857b8 'System Information'
_cdim: --- not moved 0x08185020 'nohup asd-viewer-0.1.1.1&'
s  -3/303  0/-31, g   1/334  4/ 0: --- not detected 0x081857b8 'System Information'

here, “System Information” and “Main Radar” are names of windows of my program asd-viewer-0.1.1.1

Thanks for your help

Ideally, you should be copying /usr/share/fvwm/system.fvwm2rc-sample-95 to your ~/.fvwm directory as “config” and then editing that file.

That’s not good. “xhost -” should fix that. Can you post your config file (/usr/share/fvwm/system.fvwm2rc-sample-95) somewhere, and I’ll take a look at it for you, correcting it as I go.

– Thomas Adam