no transparency


I’m working with fvwm for half a year now and it’s quite fine to work with it. That’s why I installed fvwm on my new gentoo box (as only desktop manager). Unfortanly transparency doesn’t seem to work. Including firefox that won’t start, I’m not sure if there is any link between firefox and fvwm but I just post it.
That’s strange because I have ran fvwm before on a gentoo system, and then transparency just worked. What am I doing wrong and do I need to change to let transparency work again? Because my fvwm script didn’t work fine I installed fvwm-crystal, but it (transparency) doesn’t work fine too.



In order to help you some info is needed. What does the fvwm log file contain? How do you start firefox? How is the transparency configured etc…

I’ve recently found out that transparency is really not working. Aterm is also not transparent anymore (aterm -tr +sb -sh 45 -fg white -bg black). It’s merely a X11 problem or I should install some “transperant” library.

Firefox is not the problem… it’s working now. I’m going to install eterm (with transperancy) now and going to look if eterm is working with transperancy. But I was wondering if anyone had this problem too. And mayby an answer.

What program do you use to set the background? For fvwm-root you need the -r option to make transparency work, I also thought xsetroot didn’t allow transparency, the others should be alright though :slight_smile:

hmz… strange, I installed eterm and now everything is working again. :confused:
Well, at least thank you for all your support!



Transparency was not working probably
because your config was using Esetroot
in order to set the background.
I presume Esetroot was not installed on your
system (it is not provided with fvwm).

Esetroot is provided with Eterm ; so as soon as
you installed Eterm, the background could be
set properly and transparency is working now.