Pop-up Windows are not displayed right...


im using fvwm for a few days now. But I have a little problem with windows like operas “Save As” Dialog and all these pop-up things… They dont pop up. They stay behind the current application. I need to switch the windows with ALT+Tab to get it displayed.

Does anyone have an idea what do do?

thanks in advance


These ‘pop-up’ windows are called Transient windows, hence:

Style * RaiseTransient

– Thomas Adam


i added

Style * RaiseTransient but its not working. Is it possible that this option is overriden whith an other option i set later?


Quite possibly, depending on where you put that Style line in relation to your others. The best thing I can suggest is that you upload your config file for review. You might also find:

Style * GrabFocusTransient


– Thomas Adam


My config is quite huge… I took an existing config somewhere from the homepage and changed it. But I was not really sure what i was doing :slight_smile:. Sorry…
Here is my configfile

Thanks for your help.


Well, both style lines work fine. RaiseTransient does exactly what it should. You haven’t yet said which FVWM version you’re using, but it would have to be 2.5.X based on the commands in the config file.

It’s quite possible therefore that a specific window you think is transient is not. For instance, the “test” I did here was to press the open button on gvim. That both raised and grabbed the focus of this window because I know it to be transient. FvwmIdent says so, as does xprop(1).

– Thomas.


im using fvwm version 2.5.12

When I call fvwmindent it says:
Transient No

is that right?


Presumably it is, in which case since that window is not transient, FVWM won’t consider it to “Raise” itself. For windows that are transient, then it will.

– Thomas Adam

Hmm, I See my problem has changed a little bit… When I use File->open on my Webbrowser, the window appears not an the same Workspace as my Mainwindow (in this case opera) is… It opens on a different virtual Desktop. But there in front of the other…

Any suggestions?

Can you upload your config file?

– Thomas Adam


Here is my config-file. But I don’t know what I have changed. It is quite possible that the transient windows behavior like this (opening on a new, and always the same workspace) is since i put the line

Style * RaiseTransient but i didnt notized it, because I normally use ALT+Tab to switch the windows. I didnt recognize that i switched the workspace… Sorry for that.

And thanks for answering so fast (and sorry for my bad english :slight_smile:

In Addition i have a few little things need to be changed in my config:

  • I want new windows have the keyboard focus (when i hit alt+n i open an xterm, but need to put the mouse over it, that i can start typing…)
  • I want the Programms in the Taskbar be displayed with an small application-Icon and the Application Name. e.g. xterm. Now ther is monkey@speedwagon…)
  • I need to change my Window decorations. Which seems for me quite of horrible to find out…

Greetings from rainy germany,


Style * GrabFocus

Would be the greedy match. Of course, for specific windows you can always change that:

Style XTerm GrabFocus

Of course, “monkey@speedwagon” is the name of the window. In the case of teminal emulators, you need to look inside ~/.bashrc and remove any lines are setting the PROMPT env var to your hostname. Although in the case of FvwmTaskBar, you could always try using:

*FvwmTaskBar: UseIconNames

I’d ultimately recommend you look into using FvwmIconMan instead, Monkey.

There’s efforts underway to document this on the Fvwm Wiki as well as you looking in just about any FVWM config file on this site.

– Thomas Adam

Thanks a lot for all your help. But one problem still exists:
Transient Windows are displayed not on the same Desktop as the parent Application. This drives me crazy… I put my actual config-file up here…. Can you please help me solving this? It makes it impossible to work good with fvwm for me…

Thanks a lot.