Problems with FvwmDock on remote computer

I log into another computer and start fvwm but I get this error:

FvwmIconMan: Bad line: *FvwmIconManMaxButtonWidth 150
FvwmIconMan: Unknown option: *FvwmIconManMaxButtonWidth
/home/disk10/tulsoba/.fvwm/wallpaper//test.png is 1280x1024 PNG image, color type RGB, 8 bit
FvwmDock: Cause of next X Error.
Error: 10 (BadAccess (attempt to access private resource denied))
Major opcode of failed request: 146 (Unknown: 146)
Minor opcode of failed request: 1
Resource id of failed request: 0x800007
Leaving a core dump now
xauth: error in locking authority file /home/disk10/tulsoba/.Xauthority
Building XImage…done

and as can be seen on this screenshot the taskbar that consist of the FvwmDock and the FvwmIconMan is not created:

photos1.blogger.com/blogger/3626 … titled.jpg

I have also tried log into this remote host from Cygwin in winXP and then it looks fine.

Any hints?
Any hints??

Sounds like you haven’t used ‘xauth’ to extract the necessary credentials. I assume you are using ‘ssh -X’ when you’re logging in remotely?

– Thomas Adam

I ssh in like this:

ssh -l -X -Y

No, you want:

ssh -X remotehost -l username

– Thomas Adam

It gives the same result. The FvwmDock is still messed up.

But if I change to another machine in the ssh session and the type fvwm, it looks fine…wierd. maybe I am missing a ssh option.