Titlebare disappears on restart

Each time I make a change in .fvwm2rc and chose to restart (not reboot) the titlebar around Firefox disappears and it frezese its position even if I change virtual desktop.

Is this a bug in firefox or fvwm?

No, most likely it is a “bug” in your config file – you say it freezes its position when you change pages? This suggests you have a Style line somewhere in your config that is setting the window to Sticky.

The classic example of this is with the following style line (lots of people use it):

Style *fvwm* Sticky, !Handles, !Title

The pattern matching of any Style line is always to match, based on the title first of all. Mozilla, and henceforth Firefox change their window titles such that the titlle of the window reflects the page you’re currently viewing. For instance, as I am typing this message to you now, the title of Mozilla is:

If I were to restart fvwm while viewing this page (and assuming I had the above style line defined in my config), I’d then have a web-browser that was, “Sticky” (i.e. followed me everywhere), that had no Handles (i.e. no interactive way to resize the window), and did not have a title.

So what you should do is check your config file to see if this is true of you – I suspect it is. You’re then going to ask me how to fix the issue. Well, I said that Style lines match on Title by default. If they can’t match on that they then match on Class and then Resource. Hence, for the “best” match for Firefox, use “Gecko”:

Style "Gecko"  Title, Handles, !Sticky

As an example.


– Thomas Adam

This is my style section:

Style “" BorderWidth 5, HandleWidth 5
Style "
” SloppyFocus
Style “" Icon display.xpm
Style "
” RandomPlacement, SmartPlacement
Style “" MWMButtons, MWMBorder, MWMFunctions,MWMDecor,HintOverride
Style "
” DecorateTransient,IconBox 0 -10 -280 -1
#Style “Fvwm*” NoTitle, NoHandles, Sticky, WindowListSkip,
Style “Fvwm*” BorderWidth 0,CirculateSkipIcon
Style “FvwmPager” Sticky,NoTitle,WindowListSkip,ClickToFocus,BorderWidth 1
Style “xclock” NoTitle, NoHandles, BorderWidth 2, Sticky, WindowListSkip,StaysOnTop
Style “xbiff” NoTitle, NoHandles, Sticky, WindowListSkip,ClickToFocus
Style “logout” NoTitle, Sticky, WindowListSkip, Icon xlogout.xpm
Style “gecko” Title, Handles, !Sticky

As you can see I have out-commented my first Fvwm*. I have then added Style “gecko” as the last line as you can see.

It seems to work fine when I restart. But My pagers borders are suddenly very thick, but I have specified BorderWidth to 1!

Here is all my FvwmPager settings:

Colorset 23 Transparent, fg black, bg darkgray
Style TestPager ParentalRelativity
KillModule FvwmPager TestPager
DestroyModuleConfig FvwmPager: TestPager
*TestPager: Colorset * 23

Style FvwmPager StaysOnTop
*TestPagerLabel * “Virtual Desktops”
*TestPagerGeometry 160x120-23+23
*TestPager: SolidSeparators
*TestPagerSmallFont 5x8

Colorset 25 bg black, fg black, sh black, hi black
Style TestPager BorderColorset 25

Module FvwmPager TestPager

Why does my Pagers borders enlarge when I use “gecko”?

probably there is a syntax error in your config. If FVWM comes across something it can’t handle it stops processing the config file there and then. If that happens before you get around to specifying a BorderWidth style, then you’ll get the default, which is big thick chunky borders.

A good place to look now would be that .xsession-errors file again. FVWM generally prints an error message if it has to abort a config

What command can I run to see that the resource for firefox is Gecko?


Run the FvwmIdent module. If you don’t have it in a menu, you can run it from a console

Not “a console” – FvwmConsole, or if you had “FvwmCommandS” started up in your [i]StartFunction[/] then you could (at a push) do:

FvwmCommand 'Module FvwmIdent'

(this is not for the benefit of Nick, that I explain this – but knowing some poor sole reading this, it might well confuse them.)

Generically though, you can forget FvwmIdent, and just use xwininfo or xprop. These are both standard X11 utilities.

– Thomas Adam