VMware is "sticky" although it has not been defined


I’m running fvwm-2.5.21 (latest in Gentoo’s portage) on ~amd64. My layout is 1 Desktop with 9 pages (3x3) spanned over two monitors using nvidia’s TwinView.

When I start a VMware-Session (VMware 6.0.3.x aka latest version) and go fullscreen, the window gets sticky, althoug I have no sticky-rules in the fvwm-config and sticky is also disabled in VMware(tripple-checked).

Lets say, I start an VMware-session on the upper left page and then move the mouse downwards till fvwm switches to the next page, then VMware is there, too. If I set the VMware-session to also use both monitors, it doesn’t matter in which direction I try to switch pages, VMware is always there.

This behaviours isn’t what I want, I just want the VMware-session to be only on the page I started it. I do not have this “wrong” behaviour in KDE nor in GNOME. So, is this a bug in FVWM or in VMware?

Can some reproduce what I mean? Is there a fix or workaround?


Can you please run “xprop” on the VMWare window when it is sticky and also post your fvwm2rc file someplace?


– Thomas Adam


Output from xprop (I just ran xprop > temp.txt, if I should filter it somehow, please tell me).
config - normally I have it splitted, so I cated it together and left out some stuff(keybindings, etc).

The “problem” is that the application you’re using sets “_NET_WM_ACTION_STICK” which FVWM honours. You can counteract this by using something like the following:

Style Vmware EWMHIgnoreWindowType

– Thomas Adam

Thanks, but that doesn’t work.

I’ve entered an appropriate Style-line, restarted fvwm and tried again, no change. BTW, for the blink of an eye an can see my wallpaper flashing through the vmware-window whenever I switch pages.

VMware works as expected, when not run in Fullscreen so I#m a little puzzled :confused:

I’ll uploaded a new xprop with the style-line set, you can have a look at it here.

Edit, I even set your Style-line to “*”, so it shouldn’t be a matter of a wrong ressource/class.

That’s OK. I am rapidly coming to the conclusion vmware’s another broken application. Are you sure there’s no option in vmware to disable this effect?

Furthermore, if you open FvwmConsole and put vmware into this sticky mode, does typing the following into FvwmConsole and selecting the vmware instance help?

Pick WindowStyle Slippery

– Thomas Adam

I remember running vmware-server for testing purposes some weeks ago on fvwm (.25 instead of .21, though), and I don’t remember any odd effect regarding window managent (vmware is odd enough itself, but in other regards).

I can’t guarantee it though, since I just wanted to test one thing, and I uninstalled it afterwards.

So basically what you’re saying is: “sorry, I can’t help you”. :slight_smile:


– Thomas Adam

No, what I am saying is “check it, if you can with a third person, because I don’t remember experiencing that behaviour”.



I don’t know if I’ve correctly understood what you wrote.

What I’ve done:

  1. Checked VMware options again - nothing there
  2. started an VMw-Session and set it sticky trough VMws own option and then tried your FvwmConsole-stuff -> nothing
  3. Set VMw-Session to sticky via fvwm and then did what you wrote -> nothing

This is really weird for me. The only idea left from my side is that vmw got problems with fvwm’s desktop and pages, so maybe using 3x3 desktops and not 3x3 pages could solve this - gonna try that after taking my meal, thanks so far.

I am sure you did. Look at the code:

                                fw, EWMH_STATE_UNDEFINED_HINT);
                        return 0;
                if (HAS_EWMH_INIT_STICKY_STATE(fw) !=
                        return 0;

That’s from ewmh_events.c

Try this time (in addition to the Style line I gave you previously for VMware) hence:

Style Vmware EWMHIgnoreWindowType, EWMHIgnoreStateHints

I’m having to do this blind since I don’t have any applications which set this hint.

– Thomas Adam

Again, it doesn’t change anything :frowning:

I’m going to bed now, maybe some sleep brings up some new ideas. I’m gonna make some tests with some other WMs tomorrow.

If you’ve got the time and are willing, you could get a copy and a free 30-day trial version from VMware(.com) to try it yourself - I just checked it, it doesn’t matter what kind of OS I’m trying with, same problems with FreeBSD7 as guest.

thanks so far and good night,


Tried it with OpenBox, runs as I’d like to have it aka no problem there. Didn’t try it with fvwm and the pages as single desktops, cause that would be against my intention for my config - can try it, if needed, though. Maybe I’ll have a look at VirtualBox and see if that has the same problems - might take a while, need to compile QT :frowning:

Is this done by clicking the “Fullscreen” button on the VMWare console? Doing this for me, won’t let me switch pages without first taking VMWare out of fullscreen mode.

You’re wasting your time with trying VirtualBox, by the way.

– Thomas Adam

Yes, althoug I imply it directly from the command-line (vmware -mqX $VM).

Have you activated the quickswitch-mode (see the -m in my command above or in the options) and/or pressed ctrl+alt (if you haven’t changed that) to release the cursor and focus from vmware?

Because it’s shitty software or what do you mean?

No, no. You’ve given an example of an application already doing this, so you don’t need to waste anymore time looking at VirtualBox.

– Thomas Adam

Ah, thanks. Now I have, and with FVWM 2.5.25, I don’t have any problems. I can switch from page to page without the window being sticky. I don’t have any special style lines either.

Please, try FVWM 2.5.25 and see if that gives you any problems.

Beyond what I’ve already suggested to you, I can’t help you.

– Thomas Adam

Thanks, that’s raising some hope. Well, than I’ll try to get the ebuild from here working. Currently it fails with [code]* Failed Patch: fvwm-2.5.23-translucent-menus.diff !

  • ( /usr/portage/local/x11-wm/fvwm/files/fvwm-2.5.23-translucent-menus.diff )

  • Include in your bugreport the contents of:

  • /var/tmp/portage/x11-wm/fvwm-2.5.25/temp/fvwm-2.5.23-translucent-menus.diff-20049.out

  • ERROR: x11-wm/fvwm-2.5.25 failed.

  • Call stack:

  •           ebuild.sh, line   49:  Called src_unpack
  •         environment, line 2467:  Called epatch 'src_unpack'
  •         environment, line 1213:  Called die
  • The specific snippet of code:

  •               die "Failed Patch: ${patchname}!";
  • The die message:

  • Failed Patch: fvwm-2.5.23-translucent-menus.diff![/code], but I’d say, this doesn’t belong here.

It’s doesn’t. But however, those ebuilds work. Make sure you save the patches, and not copy/paste them. If that doesn’t work, try to fetch them with wget. The patch tool is strict about line endings and the final empty line.

That’s exactly what I did, but I can try it again, later. Maybe upstream fixed something and released a new package under the same name?