Windows maximize onto next screen

Not quite sure what im doing wrong here but sometimes if i maximize a program it expands onto the next virtual desktop, such that 1/3 of the window is actually off the screen.

I then have to manually resize it which is annoying.

What command are you using to maximise, and which applications do you see this with?

– Thomas Adam

Im using:

Mouse 1 4 N Maximize

I thought i had it fixed by setting:

DesktopSize 1x1

but then it came back again. It happens with every appliaction, or sometimes it only happens to some although this changes - it doesnt seem to be appplication specific.

Other times it doesnt happen at all.

I run linux from my pen drive & i think it only happens on one of two pcs i use, but im not sure.

Either way i cant seem find a pattern or replicate the error at will.

In case anyones interested, i have no xorg.conf file because i couldnt get one to work yet.

As a result the monitor defaults to a 1900x1600 resolution. To fix this i put something like:

  • I exec Exec xrandr -s 1280x1024
    in the startup function.

However Fvwm still thinks the screen is 1900x1600 and maximises applications accordingly. The problem goes away after the i reload/restart fvwm.

Run ‘Xorg -configure’ to get Xorg to create a config that should be equivalent to how it runs without an xorg.conf file. Once you’ve verified that Xorg will start correctly using that file, go into that file, find the “Screen” section and set a default depth. Then go to the “Display” subsection for that depth and define Modes to be the resolution you want. For example, this is what I have set for my current desktop machine:

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    DefaultDepth 16

    SubSection "Display"
        Viewport   0 0
        Modes "1280x1024"
        Depth     16
    SubSection "Display"
        Viewport   0 0
        Depth     24

Replace “1280x1024” with “1024x768” and that should give you what you want.


Thanks i have tried it all before but theres some kind of a kink with my card or something. I never had any trouble putting together an corg.conf with older versions of xorg - it just doesnt want to work with 7.