2.5.16 installation problems

I’m one of those abnormal people not used to compiling programs. Still, I want that sexy translucent menus and whatnot. So I decided to apply that translucency patch to the 2.5.16 code. Everything seemed to work fine until make install when I get this:

test -z "/usr/local/bin" || mkdir -p -- . "/usr/local/bin"
  /usr/bin/install -c 'fvwm' '/usr/local/bin/fvwm'
test -z "/usr/local/share/fvwm" || mkdir -p -- . "/usr/local/share/fvwm"
 /usr/bin/install -c -m 644 'ConfigFvwmDefaults' '/usr/local/share/fvwm/ConfigFvwmDefaults'
 /usr/bin/install -c -m 644 'ConfigFvwmSetup' '/usr/local/share/fvwm/ConfigFvwmSetup'
ln: creating symbolic link `/usr/local/man/man1/fvwm2.1' to `fvwm.1': No such file or directory
Minor warning: /usr/local/man/man1/fvwm2.1 symlink was not created
test -z "/usr/local/man/man1" || mkdir -p -- . "/usr/local/man/man1"
mkdir: cannot create directory `/usr/local/man': File exists
make[2]: *** [install-man1] Error 1
make[2]: Leaving directory `/home/mandolin/fvwm-2.5.16/fvwm'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/mandolin/fvwm-2.5.16/fvwm'
make: *** [install-recursive] Error 1

Even so, fvwm and fvwm2 still get installed into /usr/local/bin and Fvwm does start, and the translucent menus do work (yay!), but unfortunately the Fvwm modules aren’t there (or aren’t working). I need those modules :frowning: Any ideas what’s missing or what I’m doing wrong?

Thanks! :slight_smile:

Edit: I’m using Debian unstable and xorg 6.9, if that helps.


I’m not sure about the make install errors. Is it possible that for some reason /usr/local/man is a file instead of a directory? Or you’re running make install as a normal user instead of root?

If the modules are installed, then from a standard compile-and-install they should be in /usr/local/libexec/fvwm/2.5.16, in which case you need to put a line near the top of your .fvwm2rc file which reads:

ModulePath /usr/local/libexec/fvwm/2.5.16

I hope this helps.


I really wouldn’t recommend this.

I suspect he needs to:

make clean

… first of all, and check there’s no cruft left over.


It turns out /usr/local/man was a symbolic link pointing to /usr/local/share/man - a directory that didn’t exist. Creating it solved the problem. Thanks a lot :slight_smile: