A problem about menustyle

Currently, I am trying to build a menu which looks flat and simple. However, when I turned off the 3D effect of the menu, the menu still shows 3D border. The configuration code is just as the follows:

[code]MenuStyle GeneralMenuStyle Fvwm
MenuStyle GeneralMenuStyle Hilight3DOff
MenuStyle GeneralMenuStyle HilightBack, ActiveFore
MenuStyle GeneralMenuStyle MenuColorset $[__CS_Menu_Inactive]
MenuStyle GeneralMenuStyle ActiveColorset $[__CS_Menu_Active]
MenuStyle GeneralMenuStyle PopupDelay 300, PopdownImmediately
MenuStyle GeneralMenuStyle PopupOffset -5 100, TitleWarpOff
MenuStyle GeneralMenuStyle BorderWidth 1
MenuStyle GeneralMenuStyle TitleUnderlines1, SeparatorsShort, TrianglesRelief
MenuStyle GeneralMenuStyle AnimationOff, AutomaticHotkeysOff
MenuStyle GeneralMenuStyle PopupAsSubmenu, HoldSubmenus, SubmenusRight
MenuStyle GeneralMenuStyle ItemFormat “%|%5.5i%1.3l%2.3>%|”
MenuStyle GeneralMenuStyle Font “xft:Bitstream Vera Sans Mono:pixelsize=12:minspace=True”

ChangeMenuStyle GeneralMenuStyle FvwmRootMenu FvwmTermMenu FvwmOfficeMenu
ChangeMenuStyle GeneralMenuStyle FvwmInternetMenu FvwmEditorsMenu FvwmMultimediaMenu
ChangeMenuStyle GeneralMenuStyle FvwmThemeMenu FvwmManPagesMenu FvwmWindowOpsMenu
ChangeMenuStyle GeneralMenuStyle FvwmColorsetMenu FvwmWallpaperMenu FvwmDecorationMenu
ChangeMenuStyle GeneralMenuStyle FvwmIconThemeMenu FvwmCursorThemeMenu
ChangeMenuStyle GeneralMenuStyle FvwmQuitMenu
ChangeMenuStyle GeneralMenuStyle FvwmMoveMenu
ChangeMenuStyle GeneralMenuStyle FvwmMultiActionMenu
ChangeMenuStyle GeneralMenuStyle FvwmPageListMenu

I tried to modify other options and these options take their effects. However, no matter how I tried to set the Hilight3DOff option, it just doesn’t work. I am wondering whether there are some other options which can also affect the 3D border effect of the menu. Can anyone help me out of the weird problem? Thanks in advance.

I suspect, since you have “BorderWidth 1”, that you want a thin, colored border around the entire menu. I think that border uses the highlight and shadow colors of the “MenuColorset” colorset. So, if you set the “hi” and “sh” colors in your “__CS_Menu_Inactive” colorset to the same color, you should see a solid border of that color around your menu.

Yeah, you are right! The problem has been solved. I had thought that the border color of the menu is automatically selected and assigned by fvwm, so I set nothing for the “hi” and “sh” in colorset configuration. And I also found out the color of the triangle, which means a submenu item, is also controlled by “hi” and “sh”. Thanks! It is really a problem bothering me a long long time.

Me too. I found the answer in someone else’s config (topic: http://fvwm.lair.be/viewtopic.php?t=415) the same night I ran across your post. Happy coincidence. One further upshot of this newfound knowledge is that we can, if we so desire, have borders around selected menu items by using “Hilight3DThin” and an appropriate colorset.

Yeah, it is really fantastic. Anyway, it will be included in my configuration definitely. :laughing: :laughing: :laughing: :laughing: