a problem with transparency in a swallowed iconman

Hi all!

I am using as top/task bar a fvwmbuttons instance which swallows 2 other fvwmbuttons (maybe not optimal) and an Iconman.
The colorset for these is transparent.
My problem is that when I log in the colorset in the iconman has some overimpression of the background, precisely of what is in the middle of the background.

Please look at the following shot to understand better what I mean:

I use normal swallowing that means:

*FvwmTopBar: ($[BL]x1, Frame 0, Swallow "FvwmBar" 'Module FvwmIconMan FvwmBar')

I do not know how to solve this issue! Even a refresh doesn’t do the thing, I can get a decent colorset only if I change the wallpaper after logging in, so not right after logging.

Moreover, I previously used the same iconman config without swalowing it in a fvwmbuttons and that worked fine.

Best regards, Brice

well I posted to fast… :blush:

I solved this by adding +0+0 at the end of the declaration line of the ButtonGeometry option for the iconman.


Well, I’m certainly glad you did post. I had the same problem.

With this it behaves much better.

well second time :open_mouth:

my solution solved the matter using this wallpaper!

By looking at the starting process of fvwm I know what goes wrong! in fact fvwm starts my fvwmbuttons, start after the iconman below the fvwmbuttons and swallows it in the fvwmbuttons what causes a crazy background in my iconman!

But to be honest I do not know how to influence that and I don’t think being able to set the wallpaper after the complete start of the module, if someone has an idea about that, you’re welcome!

Regards, Brice


I feel alone on this thread…

BTW I solved it. The trick is to indicate

ButtonGeometry 1xsomething_you_like

This “1” is decisive.


Heh, you were just too fast in answering your own question. Afaik it doesn’t have to be a 1 but FvwmButtons indeed does some odd things without a ButtonGeometry definition, so it’s always a good idea to have one :slight_smile:

I don’t blame someone… unless me! :laughing:

I am sometime a way too fast, I search for a problem, don’t find something, post in a forum, search again, solve it (or think having solved it), posted again, and so on…