A weird problem

Hi, everybody! I have a problem recently. After I run FVWM after a while, the module FvwmIconMan and keybinding will not be in effect any more. That means, when I press the hotkey which I defined in my configuration, nothing happened; when I click the FvwmIconMan, there is also no response. Except these two, everything else just works fine. Even I use the “restart” command to restart the FVWM, the keybinding and FvwmIconMan still don’t work. The only way seems to be exit the X, and run startx again.

I tried to log the error message outputed by FVWM. But there is no any message related to this. Is there anybody who can help me to figure this out? Thanks a lot!


I too had this kind of problem. When ever I increase or decrease the font size of the firefox using the hotkey “ctrl++” or “ctrl–” my key bindings used to stop working. Some how the firefox (after upgrading to 1.0.4)
is changing the hotkey definitions. Please check out whether it is the same with you.


I have tried the behavior you described on your FVWM. It did not happen in my computer. After I entered my FVWM, and then I opened the firefox, and tried the “ctrl-+” and “ctrl–”, everything worked just as before. Now I am waiting for the weird problem to happen again.

Do you use numlock to type crl++ and ctrl±, and does the weird behaviour related to numlock?

Thanks! When I turn the NumLock on, the hotkey will not work any more. When I turn the NumLock off, the hotkey will be in effect again.
So can you tell me how to solve the problem? I guess that I should add the following statement in my config file:

IgnoreModifiers 2

I will try the code right now. Thanks, zonk!

Yeah, It is the problem. After I add the statement in my config file, all the problems I mentioned before are solved perfectly. Thank god!

Better use IgnoreModifiers L2 if you don’t want to have the same problem with capslock :wink:

Yeah, I have already done that, although no problem happened when I triggered Caps Lock. Thanks for your suggestion.