Action on swallowed apps (solved)

Hi, In a fvwmbutton I’ve set :

*FvwmTime: (3x20, Swallow "Heure" 'Exec exec xclock -name Heure -digital -twentyfour -padding 2 \ -face "Swiss911 XCm BT"-16 -strftime "%H:%M:%S" -update 1 -geometry 20x20 -fg rgb:FF/9C/01 -bg rgb:20/20/20', \ Action(Mouse 3) `Exec xterm -fg white -bg DarkBlue -g 70x10 -fn 7x14 -fb 7x14bold -n "Calendar" -T "Calendrier" -e "cal -3 -m; sleep 10"`)

But no way to have the action on the right clic.
I’ve tried with Exec exec, ’ , " instead of ` in the command part of Action(Mouse 3) whithout luck.
I think it’s because the apps (xclock in this case) is managing the focus.
Here’s the style used :

Style "FvwmTime"  NoTitle, WindowListSkip, CirculateSkip, Sticky, NeverFocus, StaysOnBottom, NoHandles, RoundedCornersTop

How can I get rid of that ? Thx

Works fine here, of course. Turning off numlock is going to help.

– Thomas Adam

I already got IgnoreModifiers L25
The fact is : right-clicking on the numbers displayed by xclock doesn’t start the action. Right-clicking outside of the clock output (but still inside the button) works.
Maybe I should set some Style options to “xclock”

IgnoreModifiers is never guaranteed to work. If you want, look at the “NeverFocus” style.

– Thomas Adam

Sorry to continue but I really got something weird.
I’ve tried the same config on 3 different computers, works on 2 but on my main computer, no way to make it works :open_mouth:
On this computer I got 2 distro (archlinux / sourcemage) and on both it doesn’t work. So I have disabled Xinerama, Xmodmap for the mouse, xbindkeys, removed .Xdefaults, reconfigured Xorg but no more luck. I’ve on all 3 computers a USB keyboard and a USB mouse, the same version of Fvwm (2.5.19-patched).
Any ideas what could lead to this weird behavior ? Thx

Not really. You could post your entire config, but it’s a moot point. It could be anything.

– Thomas Adam

Anyway here’s the config file but, as I’ve said I don’t think it could be the config as it works on 2 different computers. And on my main PC it doesn’t work on archlinux/sourcemage/FreeBSD so it must be some problem with the hardware and FvwmButtons or something like this, because right-click works and I have no problem with other WM. I don’t really know how to debug that / find what’s wrecked. Thx for any answer / ideas

EDIT : hardware config

What about the output on all of your machine of:

xmodmap -pm

– Thomas Adam

Here it is :slight_smile:

[code]$ xmodmap -pm
xmodmap: up to 3 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x6d)
mod1 Alt_L (0x40), Alt_L (0x7d), Meta_L (0x9c)
mod2 Num_Lock (0x4d)
mod4 Super_L (0x7f), Hyper_L (0x80)
mod5 XF86Launch1 (0x5d), ISO_Level3_Shift (0x71), ISO_Level3_Shift (0x7c)[/code]

I’ve also tried to remove xmodmap, xbindkeys and imwheel.
As it works on other computer with diffrent hardware but same version of xorg/fvwm, I’m pretty sure this is hardware related.

Ok I get it … I have to turn off numlock to have the action working :unamused:
Any workaround ?

As I’ve said from the year dot, there’s no guarantee that IgnoreModifies will work.

– Thomas Adam

ok sorry I’ve misunderstood what you were saying, mostly because I can’t imagine numlock having action on a mouse :smiley: … anyway I’ll search for a better implementation of cal to avoid pressing numlock then right-click to have cal then repress numlock :stuck_out_tongue: :wink: