ActionIgnoresClientWindow

I have some problems with FvwmButtons.

There i have two Buttons which swallow an application. xload and xosview. And a third button with the xeyes.
A click on the xeyes schould open a bigger pager (transient) and clicks to xload and xosview should open bigger windwos with this programs.

This worked since some weeks ago. I had the original debian-fvwm package installed. (2.5.25)
But in this package is a bug with fullscreen applications like flash-videos and slideshows from ooImpress, so i compiled my own fvwm from a dayly snapshot one month ago.

And i think the clicks on the buttons worked like before. They opened the applications.
But then it only worked sometimes, and now, it doesnt work any longer. A click on the xeyes do not open the pager. A click between the xeyes opens the pager.

I found in the documentation “ActionIgnoresClientWindow” which should bring back the “old” functionality which i’ve described, because fvwm > 2.3 (or so???) will have the functionality like i want.
swallow xosview -> a click on the button opens a new window…
the old is: swallow xosview -> a click on the FRAME of this button opens a new window.

is this a bug in the current version of fvwm, or do i make some misstakes?

here are the three lines fo my fvwm2rc:

*FvwmButtons: (1x1 Frame 0 , Swallow xeyes "Exec exec xeyes&", Action "FvwmPager -transient 0 3 " ) *FvwmButtons (Action "Exec xload", 1x1 Frame 0 Swallow "xload" 'Exec xload -bg grey75 -geometry -200+0 -label jakob& ') *FvwmButtons (Action "Exec xosview +battery +net", ActionOnPress , 2x1 Frame 0 Swallow (Respawn) xosview "Exec /usr/bin/xosview -usedlabels -swap -load -page +net -network 1000000 -int -xrm 'xosview*background:grey75' -xrm 'xosview*foreground:black' -geometry -200+0 -captions +battery &")

greetings
scientific

Turn off numlock.

– Thomas Adam

Oh!

This works…

But on my other Computer i need numlock… is there another solution???

greetings

scientific

See the ‘IgnoreModifiers’ command in ‘man fvwm’.

– Thomas Adam

Sorry, i do not understand what IgnoreModifiers has to do with this problem. Mayby my english is not so good…
Pleas explain me the Solution.

greetings

scientific

Your problem, in first instance, is that you had numlock on, which completely invalidates all your bindings. What IgnoreModifiers do is to try to bypass this limitation. This way, you the bindings will work even if the relevant modifier is on.

To bypass numlock, scrolllock and capslock you use “IgnoreModifiers L25”. More info on the man page.

Sorry, i don’t get more intelligent when i read this section in the manpage…
I have “IgnoreModifiers L25” in my config. I had it inside before i realised that Num-Lock make problems to me…

But its all the same before.
Activated Num-Lock causes problems (no Action on klick on the Buttons), deactivated Num-Lock -> i get the Function i wish…
With and without “IgnoreModifiers L25”

What can i do?

Not a lot. There is no guarantee IgnoreModifiers will work, and it’s a real kludge anyway.

– Thomas Adam

i’m thinking this ugly word, starting with f…

or do you think, there is a solution possible with xmodmap or something? i’m not really firm in this topics…

greetings

scientific