Annoying error message

I’ve got an annoying little problem with fvwm. The following error message is generated every time i switch desktop using GotoDesk:

[FVWM.0][__execute_function]: <<ERROR>> No such command '0' [FVWM.0][__execute_function]: <<ERROR>> No such command '1' [FVWM.0][__execute_function]: <<ERROR>> No such command '2' [FVWM.0][__execute_function]: <<ERROR>> No such command '3'
Switching to desktop 1 generates the first line, to the second desktop generates the second one and so on.
I have the following keyboard shortcuts defined:

Key 1 A 4 GotoDesk 0 0 Key 2 A 4 GotoDesk 0 1 Key 3 A 4 GotoDesk 0 2 Key 4 A 4 GotoDesk 0 3
4 is the windows key.

Any ideas?

Chances are you have defined a function called ‘‘GotoDesk’’ somewhere.

– Thomas Adam

Thanks for your reply!

I ran “grep gotodesk * -ir” in my ~/.fvwm directory and the only results i got was the keyboard shortcuts I mentioned in my first post…

What version of FVWM? Can you upload your config somewhere?

– Thomas Adam

My FVWM config files
That’s only the config files, do you want all icons, images and scripts as well?

Edit: spelling

$ fvwm -V fvwm 2.5.16 compiled on Sep 8 2006 at 23:09:18 with support for: ReadLine, XPM, PNG, Shape, XShm, SM, XRender, XFT
Sorry, forgot :blush:

Given that FVWM 2.5.18 has now been released, start using that. Note that I cannot reproduce your “bug” – if it is indeed even one, since although you get that error message, it still seems to work just fine.

If upgrading to 2.5.18 doesn’t solve it, let me know.

– Thomas Adam

I upgraded yesterday and I still get the same error. It’s not that imortant really, it’s just annoying, i want FVWM to run without errors :slight_smile:

Anyway, thanks for your help!