Badly behaving applications and xterm

Hi all,

I’m an embedded software engineer and I’ve been using fvwm since '94 and have stuck with it at work and home through various versions of Sun, Solaris, Windows (cygwin), & Linux. I’ve always used xterm but lately Brave Browser and Skype seem to be messing with my xterms, with Brave being the worst of the two. I’ve upgraded to fvwm3, version 1.0.4 but saw the same problem in fvwm2. I’m running a two monitor system, one a 4k monitor and the other a WXGA. I’ve got an NVidia graphics card (T600 processor, NVIDIA 470.103.01 drivers). I’m running Ubuntu 20.04. Xinerama is installed. When the applications are running, I sometimes (but not always) get double lines in my xterm after a press of enter or return:

What’s odd is that if I highlight the double text with the mouse or take a screen grab the double text goes away. If I hover over one of the problematic application, the text in the double-lined xterms start to jump and flicker. If I quit and restart the problem applications or even switch to a different desktop and back the problem clears for existing text, but entering new carriage returns in the xterm causes the problem to return. Once this problem starts I often have to exit fvwm to make it stop; not even a fvwm restart fixes the problem. And it only seems to impact xterm - lxterminal does not exhibit this problem. I’ve never seen this problem on my single monitor system with the same 4k monitor running fvwm2 and Debian 10.

I’ve tried mucking around with various xterm settings to no avail - the problem still occurs in a simple “xterm”, no options. Likewise the problem occurs while both at the shell and within vim. I can dump Brave but I need Skype for my job. Since nothing crashes, just the display acts funny, I don’t know if there would be any logs. Is there anything I can do to fix or investigate this?

Thanks,
Michael

Hello Michael,

This doesn’t sound like a FVWM problem to me – but probably a graphics driver issue? Do you see the same thing with XTerm using a different window manager?

Kindly,
Thomas

I’m running Ubuntu (not my first choice) and the only other desktop installed is the Ubuntu desktop, which is very painful to use. I believe I tried it under the Ubuntu desktop and did not see the problem, but I will try again in the next day or two to confirm.

I ran under the Ubuntu desktop for about 20 minutes and didn’t see it. But then launched into FVWM and didn’t see the problem until I joined a meeting and shared my desktop with the Skype app. I’ll test some more to try to narrow down the trigger.