BUG: xterm icon label not displayed properly?


Not sure if this is xterm issue or fvwm.

fvwm 2.6.6 compiled on Jul 15 2016 at 13:02:34
Fedora 24: 4.9.8-100.fc24.x86_64

Start xterm as: xterm -T T11 -n N11
The title shows as T11. Iconify, the icon label is also T11. I was expecting N11 (fvwm identify properly shows Name of T11 and icon name of N11).
Now, do:
bash> echo -ne “\033]0;T22\007”

The window title changes to T22. Iconify, and the icon label remains T11. Do fvwm identify, and it shows Name: T22 and Icon Name: T22. Again, do:

echo -ne “\033]0;T33\007”

Title changes to T33, now icon label upon iconifying shows T22!!

So, looks like xterm icon label is now showing properly when iconified!


Please try 2.6.7. There was a bug that was fixed somewhere there that dealt with something similar to this. I would have to track down the details, but please try the current stable release and see if the issue is the same.

Thanks for the reply. Tried 2.6.7 and exact same problem.

I cannot confirm the issue with rxvt, but I have similar problem with some apps.
Take for example Xfe. FVWM for no reason shows only previous title which Xfe set a step back.

Here, https://yadi.sk/i/9-UoPL7u3E6Xb3, it shows both titlebar and identify all matching titles. However if I just iconify it - https://yadi.sk/i/htoWhyHC3E6XoT, it shows previous title Xfe did set when it was in /mnt directory.

I remember some apps also suffer from this, while most others behave sane.

My matching configuration is there]http://fvwm.org/screenshots/2017-02-03_Andrey_Startsev-1290x1024/fvwmcfg.tar.gz[/url]. FVWM version 2.6.5.

Anyways please try 2.6.7 and see if you still have the issue lynxlynx.

As for the actual issue of fvwm updating the name/icon name of a window there have been some issues that maybe related, there is this bugreport from debian


which seems to say a fix for the issue there was fixed, but I think this is a different issue. This was not correctly using WM_ICON_NAME vs WM_NAME which seems to be different than it not being updated. So I searched the mailing list archives.


So there is an older issue in which trying to fix this issue caused a crash and the fix for the crashes was this issue is still present. I’m unsure if any work has been done on this. You may want to send an email to fvwm-workers to report this bug. In the report be clear on how to reproduce it and it may or may not get attention (fvwm development is slow, but bug reports are addressed sometimes).

So seems this bug was known about, but has just kinda been put aside.

Thanks for tips somiaj!

fvwm 2.6.7 still has this, but indeed a link to mailing list thread did help.
I played around with TitleFormat / IconTitleFormat and determined that either

TitleFormat %i
IconTitleFormat %i

, or

TitleFormat %n
IconTitleFormat %i

do solve my issue.


TitleFormat %n
IconTitleFormat %n

I see the issue is the same.

I tested it in a test user with:

fvwm 2.6.7 compiled on Feb 18 2017 at 00:47:05
with support for: ReadLine, XPM, Shape, XShm, SM, Bidi text, Xinerama, XRender, XCursor, XFT, NLS

This diff also solves this issue without .fvwmrc adjusting:

--- fvwm-2.6.7.o/fvwm/add_window.c
+++ fvwm-2.6.7/fvwm/add_window.c
@@ -586,7 +586,7 @@
 		format = (style->flags.has_icon_title_format_string) ?
+			"%i";
 	} else {
 		format = (style->flags.has_title_format_string) ?
--- fvwm-2.6.7.o/fvwm/style.c
+++ fvwm-2.6.7/fvwm/style.c
@@ -2978,7 +2978,7 @@
 			if (fmt_string == NULL)
-				fmt_string = DEFAULT_TITLE_FORMAT;
+				fmt_string = "%i";
 			if (!__validate_titleformat_string(fmt_string))

So now it works fine 8)

send the patch to fvwm-workers or make a pull request against the git source.

Anyways glad that helps.

Tried TitleFormat / IconTitleFormat, that seems to work if I restart fvwm everytime.

Will try the patch in couple days.


Yup, the patch worked. I hope you will submit it.

(TitleFormat / IconTitleFormat didn’t work for me, as changing the title/icon-name required fvwm restart for it to work properly).

thanks a lot.

I’d already sent a more clean version of it to fvwm-workers list. Hope it will be reviewed soon.
Anyway I’m glad it helped you too! :astonished:

Dominik Vogt worked on this and patch github.com/fvwmorg/fvwm/commit/ … 400c.patch solved this issue. He recommends to test it to anyone who has this problem.