Cadence Layout/Schematic Editor Mouse Problem

Using fvwm 2.6.8, but also tried it with 2.6.5. I am using an empty local .fvwmrc file, so I am not overriding any buttons.
Running Cadence Virtuoso ICADVM18.1-64b.600.2
Running on Linus through VNC.
I had a similar setup at previous two companies which worked (older versions of software), but at my new employer I see something strange.

When I open a schematic, a quick (less than 0.1 second?) left-button mouse click is not passed through in the editor window.

A quick button press works as it should in Virtuoso menus and all other applications, but if I try to select an object the the graphical editing window, a quick click does not go through. If I hold the mouse button down a tiny bit longer (> 0.2 seconds?) without moving, the button press event does get through to Cadence to select the object. If I kill fvwm or use another window manager like twm or Gnome then the problem goes away. The middle or right mouse button do not have the problem, they respond immediately, only the left mouse button has this strange lag.

Has anyone else seen this? I really don’t want to change window managers after 15+ years, but this is annoying enough that I guess I am switching to Gnome for now. Sometimes when I try something like a middle mouse button drag I see an error message:
[fvwm][ComplexFunction]: <> Grab failed in function EWMHActivateWindowFunc, unable to execute immediate action
I’m not sure if that is related. Running fvwm --debug doesn’t report anything. Maybe the problem is related to Cadence Strokes which I’ve never used before, but those come from the right mouse button and seem to be working fine.

i am a pretty new user, but I noticed a draw back to having double click functions defined for titlebar buttons. If you have your double click time set high, then fvwm waits until that time is over to determine that you are not doing a double click. This can cause noticeable lag when you single click a titlebar button that also has a double click function.

Maybe try setting your double click speed really low to test this out.

Here is what i use:
ClickTime 225

Maybe there is a mouse double click function defined for the application window.

I use cadence through tigerVNC and Exceed on Demand. I only interact with schematics. I have not seen this problem.