can't figure out which config file is loading

I have a config file in my home directory ($HOME/.fvwm/.fvwm2rc) and i have a different config file for my root user (/root/.fvwm/.fvwm2rc).

The only thing is, when i start fvwm it loads some other config that i may have floating around somewhere that i downloaded sometime. And it clearly isn’t loading the config files i mentioned before.

How would i go about finding and deleting this config? Is there a way to specify what config loads, having it point to the config in my home directory?

– Thomas Adam

I’ve read that in the beginner guides already, so I already read that. But that still doesn’t help me. It’s loading a config file that I don’t know where it is. And since it would probably be labeled something .fvwm it won’t appear when i’m looking in a file manager. I want to either delete this config that it’s loading or edit it to my liking. The only thing is that i don’t know the name of the file or which directory it is in. Is there a command i can run in fvwm that will tell me the config file it is currently using (name and directory). By the way i’m running gentoo.

So? You never mentioned that, and the detail with which you posed your question (that’s a subtle hint) doesn’t lend its weight to me being able to know that, let alone infer it.

So yet again, can you actually just try and tell me what it is you’re seeing or FVWM is doing to make you think there’s some other file being loaded? Please read the following:


That’s the most in-depth post I’ve ever written about startup on these forums. Note that depending on your symptoms, FVWM will ALWAYS read in ConfigFvwmDefaults – which is found in $(fvwm-config -d). Which version of FVWM are you running?

– Thomas Adam

Enable your file manager to view hidden files so file names that begin with “.” will show up.


ls -a

– Thomas Adam

Sorry if it wasn’t clear in my original post. But all i really was wondering is how to see what files are marked as hidden. Using “ls -a”.

It turns out that for my user it was loading a config from the directory $HOME/.fvwm/config. Thanks to enabling hidden files in my file manager i was able to see that this file existed. The config that i have been tweeking was in the directory $HOME/.fvwm/.fvwm2rc.

Thanks for all the help. It seems to be all the simple “easy” things that are the hardest. But now i’m on the right track.