can't open display

When I want to start fvwm2 in the command prompt, I get the error:

[fvwm][main]: <> can’t open display sysadmin1:0.0

I also tried ‘fvwm2 -f /root/.fvwm2rc -d sysadmin1:0.0 -s’ -> this also didn’t work

I also tried to put the ‘setenv DISPLAY sysadmin1:0.0’ line in the .fvwm2rc file, this also didn’t work.

I made a .xinitrc file with in it the line ‘fvwm2 &’ -> when I try a startx, I get the following error:

Errors from xkbcomp are not fatal to the X server

Waiting for X server to shut down

, but I’m in run level 3, and the X server hasn’t even started yet.

FYI I use: Red Hat 7.2 with both KDE and Gnome installed, and this with fvwm version 2.5.23

Any Ideas?

You have to actually start applications as the user that’s already opened to the display. But your problem extends before that because you probably don’t even have a display open, or one is already open with some sort of display manager, for instance.

Your best bet is to tail -f /var/log/Xorg.0.log to see what’s going on.

– Thomas Adam

I guess Red Hat 7.2 works with XFree so…look at /var/log/XFree.n.log

don’t know wheather the current fvwm will work because of some specific dependencies?