Can't start FvwmButtons

I have made the following in my .fvwm2rc file:

AddToFunc StartFunction
+ I Module FvwmButtons

Style "FvwmButtons" NoTitle, Sticky
*FvwmButtons: BoxSize smart
*FvwmButtons: Frame 0
*FvwmButtons: Padding 0 0
*FvwmButtons: Geometry 1280x24+0-0
*FvwmButtons: Rows 5
*FvwmButtons: Columns 1280

But nothing happens when I restart fvwm.

Yes, it does, it loads – you just haven’t told it to draw any buttons…:

*FvwmButtons: (1x1, Swallow(Respawn) "xclock" "Exec exec xclock")

– Thomas Adam

Ok, but I only get a blank grey bar in the bottom, should the xclock not suppose to appear?

It ought to. Have a look at other people’s configs for FvwmButtons ideas, too.

– Thomas Adam

I am currently looking at 3 different configs. But to make the xclock work I think I need to mess around with the .Xdefaults file.

Why? That file will only alter the appearance of xclock – the line as I have it for FvwmButtons works here for me.

– Thomas Adam

It works if I make it like this:

*FvwmButtons: (205x1, Swallow “xclock” “Exec exec xclock -d -geom 205x24”)

The “Columns” option for FvwmButtons holds the number of button widths along the width of a button bar. You declared:

*FvwmButtons: Columns 1280

which means you wish to have 1280 buttons along the width of the screen. Since I take it that your screen is 1280 pixels wide (because you delcared the geometry of the FvwmButtons module to be 1280x24), you have made with this “Columns” option 1280 buttons, each 1 pixel wide. The geometry for single buttons within the module are given as button widths and heights. So your swallowed xclock here, with the geometry 205x1, has a width of 205 button-widths (that is, pixels as you have it set up). You might rather have something like:

*FvwmButtons: Columns 53

if you want square buttons in your bar. This is 1280/24 (24 from your overall geometry specification) rounded down. It would be larger if you wanted rectangular buttons.