Check mail in the TaskBar?

I am trying to make the mail check work in FvwmTaskBar. I have tried the following:

#*FvwmTaskBar: MailBox /var/spool/mail/
#*FvwmTaskBar: MailBox /home/me/.evolution/mail/local
*FvwmTaskBar: MailBox /var/mail/spool/$USER

*FvwmTaskBar: MailCommand Exec exec evolution
*FvwmTaskBar: MailCheck 3

But when I send a mail nothing happens. I have two accounts. One Yahoo and one from a paid firm. Does this have anything to say?

Assuming your mail-spool is /var/spool/mail/$USER, then that line above is the right one to use.

Well, that depends. Does your mail end up in /var/spool/mail/$USER? Which MUA do you use? If it’s maildir format, it won’t work.

– Thomas Adam

With or without the “$USER”.

If I make a new mail and send it to myself and at the same time look in the (using konqueror):


I seem something going on when I receive the mail.

Nothing happens in

I guess its only when I reboot that something changes.

OK. Is that “going on” in the FvwmTaskBar?

Well, no. It wouldn’t unless you had mail sent there. Which is why you can specify whatever path you like.

No. That’s an incorrect assumption.

– Thomas Adam


OK. Is that “going on” in the FvwmTaskBar?


I am not sure what you mean. Nothing happens in the right corner. I thought there would come a little white letter.

But it does not make any sense. It is first when I check my mail in evolution that changes are made in /home/me/.evolution/mail/local.

So for the TaskBar to be aware of new mail I should first try to receive it through evolution, but then there would be no point in getting the notification.

I can’t seem to find out which argument I should give:

*FvwmTaskBar: MailBox.

I use Ubuntu Linux and I have the following 3 directories that I have also tried without any success:

(in both these directories there is a file called “me”)

I have to keep an SSH connection open to a server to get access to the internet, maybe it has something to do with this?

To my unknowledged mind, FvwmTaskBar only polls a local file for new lines.
Simple. FvwmTaskBar didn’t work for my procmail-driven setup all that well. If I remember correctly, the manpage for it should give you more insight as to why.
But, if you have one simple traditional mbox style spool file living in /var/, and evolution isn’t fetching mail from remote machine (and if it is, have a look for a program called ‘fetchmail’), then you should have no problems with FvwmTaskBar’s mail notification (apart from, again, iirc, you have to manually middle-click the mail icon to let it know you have read your new mail in evolution)

So, based on the assumption you get the mail eventually to local machine (ie. in the machine where FvwmTaskBar is running), and mail receiving services are putting things into their default locations, my advice is to try out not defining the *FvwmTaskBar: MailBox at all.
Also, the polling sequence could not be so dense that you wouldn’t get the notification right away. Wait a minute or two.

It also only works for mbox format.

– Thomas Adam

How do I know if I have mbox format? I use Evolution, but does it matter which mail program that I use?

I have now installed fetchmail and used the fetchmailconf to set up the program to get my Yahoo mail. And when I send a mail to myself (using evolution) and use fetchmail to get it, the mail seems to be put in /var/mail/me.

I have then made Evolution get the mail from this local file (/var/mail/me) and it works fine. In Evolution it even says that its an mBox format.

I have then made the following in my .fvwm2rc file:

*FvwmTaskBar: MailBox /var/mail/me
*FvwmTaskBar: MailCommand Exec exec evolution
*FvwmTaskBar: MailCheck 3

But still nothing happens in the taskbar when I recieve new mail with fetchmail.

Eventhough it seems to work I get this error when using fetchmail in debugger mode:

fetchmail: SMTP> RCPT TO:<tulsoba@localhost>
fetchmail: SMTP< 550 <tulsoba@localhost>: Recipient address rejected: User
unknown in local recipient table
fetchmail: SMTP error: 550 <tulsoba@localhost>: Recipient address rejected:
User unknown in local recipient table
fetchmail: SMTP listener doesn't like recipient address `tulsoba@localhost'
fetchmail: SMTP< 220 localhost.localdomain ESMTP Postfix (Ubuntu)
fetchmail: SMTP> HELO localhost
fetchmail: SMTP< 250 localhost.localdomain