Chrome 'picture-in-picture' window ignores 'Borders' style

If you start playing a video on youtube.com in Chrome, the browser creates a new button (☰♪) on its toolbar. If you click on the button, a popup appears that has a button “Enter picture-in-picture”. After clicking the button, Chrome opens a separate window with the video. Such a window has no borders.

FvwmIdent says it has NoClass & it’s not a transient window. If I try

Style NoClass Borders

the PIP window still stays borderless.

I also have

+ "Borders"              Pick (CirculateHit) Style $[w.name] Borders
+ "No Borders"           Pick (CirculateHit) Style $[w.name] !Borders

attached to a menu for a title button: the toggling works for every window, except for the PIP one.

Style * EWMHIgnoreStateHints

doesn’t help too.

Hi @alex2

Indeed. The best you can hope for is !MwmDecor as a style option. There’s not anything fvwm can do here to help.

unfortunately, setting !MwmDecor didn’t make any difference :(

It won’t do – at besat you’ll only get the titlebar. Same reason for why Microsoft Teams doesn’t have a border. Best bet, swallow “Player-in-player” in FvwmButtons.