Clean and (can be) green.

stonecrest config

Clean and Green theme created by Scott Horowitz

I fooled around with fvwm a while back but just didn’t have the time to finish my theme. Well I’m back now and loving it again :smiley:

Thanks to sascha/pem for the efficient thumbnailing in c, works great on my 600mhz box! I also like the effect I made for the fvwm “dock” where the icons come out of the dock when you mouseover on them. Just a little useless eyecandy.

Just have to add a right-click menu on the desktop and I’m set…


The screenshot looks really good.

Can you post the config file or you can send the configuration to



A very good job, indeed :smiley:

Matching colors, and a clean layout.

Keep it up,


Very nice screenshot. Good job. I like the cleaness of it!

Okay, I’ve added right-click menus for the desktop and apps, added a MPD script to my dock, added a ‘show desktop’ (or thumbnail all) icon, and other stuff. A few more things to do but I’m very content with it.

Some screenshots:

Here is the current config. Note that it will look pretty badly for screen resolutions other than 1024x768 (mostly just the wallpaper will be screwed up, I think, since the dock tint is hardcoded in the wallpaper…). If anyone modifies it for themselves and wants to share their changes, I’d appreciate that.


very nice, really clean (and green) :slight_smile:.
A great job!

This is really nice. Thank’s for a nice theme.
So clean …

Thanks guys :smiley:

I’ve added a calendar script to the config (updated in first post)… You click on the time to show/hide it. I might make it fancier in the future but it gets the job done.

Not all programs generate thumbnails when I minimize them. For example terminal and opera. Is this a known issue or is it something in my setup?

You have to add them to the fvwm2rc.applications file and restart fvwm (middle-click on desktop), I only have it set up for the applications that I use. It should be quite obvious how to do that.

Also, let me know what you added to the file so I can throw it into the config on my end for future people.

I added < Style ** EWMHMiniIconOverride, IconOverride, MiniIcon none.png > so that even though you don’t have set up the icon you’ll get the thumbnail of the program.

I’m a noob, so bear with me :slight_smile:

I just installed Clean and Green. Looks good and works great BUT I can’t see the small thumnails at all. When I minimize Firefox it just disappears. I can get it back with Alt-Tab but I think I’m supposed to see a small thumbnail somewhere. What might be wrong?

Where does one add the above code (fvwm2rc.applications probably, but where there)? And do I also need a none.png file?

Good idea pomj, I have added that code for people who have different applications than myself. Paapaa, just redownload the tar.gz file above. As for your Firefox problem, it means that your application is not Firefox-bin like mine is. In order to find out what you should put in the fvwm.applications file instead, left-click on the top-left corner of firefox (where you’d expect the mini icon to show up). It should bring up FvwmIdent - you want to replace “Firefox-bin” in the file with whatever shows up as firefox’s Class.

Anyway, I’ve fixed a couple bugs that I had stupidly introduced. I’ve also added a little graphical quit menu (quit fvwm, reboot, shutdown):

You’ll need to have your user set up with sudo to take advantage of the shutdown and reboot options. Eventually I want to make it with FvwmButtons instead of FvwmScript so that you get a neat mouseOver effect (maybe greyscale to color) but I haven’t the time right now.


I like it very much, especially the icons.

Where du u get them?

I think i´ll use ur config as base for a new one. (I´ve got four at the moment :wink: )

But i´ll add a better/bigger menu and i´ll include/swallow an iconman in ur panel.

Thanks so far.


The icons are from nuoveXT: It’s the best icon theme I’ve ever seen.

The guy who made it also has a preview for a new theme he’s creating based on the one above:

And he’s also made a firefox icon theme that goes along with his icon themes: … tent=28420


Thanks for the help but it didn’t quite help :frowning: I’m actually using Firefox-bin (I’m using Gentoo and emerged the binary version of Firefox). The Class line says “Firefox-bin” and resource line “firefox-bin”. So the line in fvwm2rc.applications should be ok.

Is there any way to debug what happens when I try to minimize the screen (using the lefmost icon in the titlebar). Could there be a wrong path somewhere, wrong permissions or what? I’m working as a normal user. Didn’t try root user yet.

Any help is appreciated!

Hmm, did you try firefox-bin uncapitalized? You could also try using wildcards like:

Style "*irefox*" MiniIcon icons/firefox48.png

Sometimes the applications are weird about how to reference them.

Thanks for the links :d

I tried all that and it didn’t help. Then I saw something when I first minimized Firefox and then immediately quit X window. I saw one page of X window debug info (is it stored somewhere in a log file??) stating that I am missing some libIm2… file. There is most likely some library “thumb” is using which I don’t have. Can you help where to get it?

I think I found it. It seems to be “imlib2” library which I have to install. I’ll report back later.

That was it!! :smiley: I just had to “emerge imlib2” and now the tumbnails work like a charm. Where is the source of thumb? Was it anything like this


Oh right. :blush: I assumed that only firefox was giving you problems, not all applications. I should include imlib2 as a requirement (i should probably add a README file too heh).

And yes, thumb is the code included by pem in that thread. I also have a thumbshadow in /scripts that adds shadows to the thumbnail window but I haven’t enabled it by default yet. If you want to try it out, just replace ‘thumb’ with ‘thumbshadow’ in fvwm2rc.thumbnails.