colorset RootTransparent bug?

I’m having a problem with a colorset and I’m wondering if it is in fact a bug.

Here is the scenario: I have an FvwmButton on the root desktop, that contains some text. The colorset this buttons uses is this:

Colorset 51 fg white, fgsh black, RootTransparent buffer

Basically I want this text to be white with a black shadow, and sit on the root desktop.

Here is the problem: When the transparency kicks in, it changes the shadow to green. I’m assuming it chooses green because there is a lot of green in the background. This only happens on the first load. When I reset fvwm the black shadow appears fine.

Any ideas?

[color=red]Edited by theBlackDragon:
–> Moved from Basic questions.[/color]

It might be a bug – although the use of “buffer” to your RootTransparency is far from advisable, it slows things down.

– Thomas Adam

Ok I just read what buffer does in the manpage… maybe this will add a in little speed.

BTW - I still get the green effect without buffer.

Try also setting sh, iirc the value for this gets computed if you don’t specify it.

I treid it but still the same problem… I did this:

Colorset 51 fg white, fgsh black, sh black, RootTransparent