compilation on mandriva problem

OK, I’ve just started planying with Mandriva 2011, and tried to compile fvwm-2.6.2 on it. For some reason the configure script is not finding libstroke, but I don’t see why, since both libstroke and libstroke-devel are installed (from the mandriva repos), version 0.5.1. There are four other libraries it’s not finding (libreadline, librplay, librsvg), but I’m not too concerned about those. I also tried 2.6.2 and 2.7.0 but the same behavior of those missing libs results.

Any hints as to what I might try? I have no idea whether fvwm will work with mandriva 2011, with its KDE/GNOME combo desktop, but I thought I would give it a try.

fvwm-2.6.2 compiles fine on Scientific Linux 6.0 for me, missing only librplay and two of the FvwmGtk support libs, which I never use anyway.

Obviously without the config.log file, no.

That said the likely reason they’re not found is incorrect search paths for library files, of which ./configure has options to tell it where to find them.

– Thomas Adam