Compiling 2.5x on OSX

I tried compiling myself the latest release, but the configure cannot find xpm.h, and so can’t I. Do I need some additional stuff installed in mac first? I think I’m missing all the X headers, but I have installed the Apple provided, which I thought had everything necassery.
Fink has only older version and I don’t want darwinports (I have too much stuff already). Could someone give a hint? Thanks

I suggest first installing the old fvwm 2.4.18 version via fink; it will also install a number of packages that fvwm needs in order to run.
The file /sw/fink/10.3/stable/main/finkinfo/x11-wm/ contains the list of dependencies of fvwm.

Then compile the more recent version of fvwm; make sure first that some recent version of libpng is installed on your system if you want png support :
sudo apt-get libpng3

here are the options i used for compiling fvwm 2.5.13 :

sudo ./configure --prefix=/sw --libexecdir=’${prefix}/lib’ --mandir=’${prefix}/share/man’ --with-iconpath=/usr/X11R6/includes/X11/bitmaps:/sw/share/bitmaps:/sw/share/pixmaps --with-png-library=/sw/lib --with-png-includes=/sw/include


sudo make RANLIB=“ranlib -c” CC=“gcc -L/sw/lib”

Note that i didn’t try to include support for Stroke :
fvwm 2.5.13 compiled on Jul 29 2005 at 23:46:07 with support for: XPM, PNG, Shape, XShm, SM, Xinerama, XRender, XFT
Also i am not using Apple X11 but XDarwin, but i don’t think that it makes a difference.
Hope this helps.

Thanks for reply!

Unfortunately, your very nice instructions didn’t help; config can’t find libpng for me (I have it installed), nor xft support, nor xpm image support. So, it doesn’t find anything even when explicitly told the location. I think I’m missing something very basic…

EDIT: Found out it was the XSDK from the osx install cd, that I was missing. (Still no xft support, tho)

UPDATE: Finally got it to compile.
Here is what I did (I find Fink old and confusing because programs are sliced up):

  1. Install the Apple provided X11
  2. Install the XSDK from the OSX cd1
  3. Download and compile and install libpng
  4. go to fvwm source tree and ./configure --with-png-includes=/the/path/where/you/installed/them --with-png-library=/the/path/you/get/the/idea -with-xft-prefix=/usr/X11R6 --with-freetype-prefix=/usr/X11R6 --with-fontconfig-prefix=/usr/X11R6

(the last three were causing me headache)
5) make RANLIB=“ranlib -c” CC=“gcc -L/the/path/to/the/png/lib”
(Just as harven said, thanks again harven!)