Condition "Visible" does not seem to work along with xcompmg


I noticed, that “Visible” condition does not work when I am running xcompmgr. Turning it off fixes it though. Is it somehow possible to make the condition to work along with xcompmgr ? Or is there other way of checking for a window if it is burried beneath other windows ? (I checked “Overlapped” condition, but I did not prove to solve the problem).


I don’t use Xcompmgr, but I just tested and I can’t see any problem with it and
the Visible or Overlapped conditions. Can you describe in a more explicit way
what are you trying to do, your Xcompmgr settings and what the results are?

– Jesús Guerrero

I would like to auto-iconify windows that are not visible on the screen anymore. To do that one would simply invoke:

All (CurrentPage, !Visible) Iconify True

However, this command does not have any effect when I am running xcompmgr at the same time. I tried running it with all sorts of arguments, but with no luck.

I see, I can now reproduce the bug, though I can’t tell you if it is xcompmgr
or fvwm’s side. I have no solution, though I can give you an advice: this
question seems a perfect candidate for the fvwm-workers mailing list.

Maybe someone around there can help you. There is info on how to join and use
the lists at the fvwm site.

– Jesús Guerrero