creating an rpm file


So, I love fvwm and want it on all my machines. So, I am going to pull windows 98 off of an old box and I installed redhat linux on it.

However, after reading up on rpm, I want to figure out how to take an rpm file off of my current box, and install it on the older box. (just so I know how to do it).

I followed the steps outlined on: and I have created an rpm file from the tar.gz that I downloaded from the download page of

However, after looking at some other sites and docs, it seems that some people are saying that I have to create this rpm file that I want to install on my target computer from the fvwm source files (whatever thay are) instead of from the fvwm that I have installed on my computer.

So, do I need to download the fvwm source files, install those on my computer, make an rpm from those installed source files, and then install that ‘fvwm source’ based rpm onto the target box? Or can I create a viable rpm from the tar.gz files found at: ?

I am hoping that creating an rpm from the tar.gz found on the download page of will allow me to copy that rpm file over to the target box, and simply type rpm -i foo.rpm and it will install fvwm onto that box. Of course, I will then need to copy my .fvwm2rc file, but that is easily done.

Also, what about any themes that I might have installed on my current computer? Are they included in the rpm that I make? Or is there something more that must be done?

Ya, stupid questions, I know, but if anyone has done this before, I would really appreciate any thoughts before I blow the living crap out of my target box.


[color=red]Edited by theBlackDragon:
–> Moved from Basic questions: basic questions is NO default location for your posts, please consider posting in the appropriate forum, this is not personal at you, skenderberg, but to ALL the people that just post in Basic questions without even considering the other forums.[/color]

as far as I know, an rpm is a precompiled package so you don’t need the source to install the software. But when you want to make you own rpm-file, I guess you’re the one who needs to precompile the software, so yes, you’ll need the fvwm-source on the computer that will generate the rpm.

however, I never did this as I hated the rpm-system as a newbe. switcht to gentoo :slight_smile:
As I didn’t use rpm much, I don’t know if it’s possible to just pack the already compiled fvwm on your system without having to compile it. I think it would cause difficulties to find out which files belong to fvwm.

that’s all I know, I hope my answer is helpfull.


Wasn’t that what this discussion was about?

Btw, this doesn’t cound as a basic question, rather as an installation related question insofar that it is no duplicate of that previous post.


I apologize for posting this message in the wrong forum – it was not on purpose. I didn’t think to consider building an rpm to be part of installation – however, upon reflection, it is ALL about installation isn’t it? :slight_smile: I will use more care in the future.

So, it appears that yes, to build my own, local version, of the source files for fvwm (e.g., editing the fvwm source, and then using that edited version) will require building my own rpm-binary-package on my local system from the source files, and then installing that binary onto the target system of my choice.

I guess that I will try that next (downloading and installing the fvwm source rpm onto my computer, and then creating an rpm binary package from the source files)-- unless someone has any other suggestions?

Thanks again,

Creating a binary rpm from the source rpm is quite straightforward iirc, it’s been a long time since I last used rpm’s though, but why don’t you just grab a binary rpm then? But as the other thread suggests there is a switch to configure that creates an rpm for you though it seems to be out of date, posting this on the fvwm mailinglist might get this fixed in cvs in no time though (if it’s not already fixed), so you might want to go down that road.

As for the wrong place posting, it wasn’t meant to be personal, but a lot of people just post in Basic questions and well, I got annoyed and you had the bad luck of being the one in whose post I expressed my annoyance…




I installed the support rpm’s necessary to install FVWM on Fedora Core 2. When I tried to install the rpm by the following:

rpm -i fvwm-2.5.13-1.i386.rpm

I get the following error:

I, still being new to the Linux world, am a little bit lost by this. I’ve looked on google, but with no satisfactory outcome.

any suggestions would be appreciated.

thanks in advance,

This has already been answered, by me, infact. :0 tBD already pointed this out.

As to why that file is missing, I suspect you’re missing some rpm-dev package, but you’ll have to find a mailing-list specific to your distro, I’m afraid. This is not a “catch all” forum. It’s really just FVWM.

– Thomas Adam

Thanks to tBD and Thomas Adam for all their help… but I am stuck on getting the rpm to work:

NOTE: I fixed the security problem that I was having, but now I have a question that is FVWM specific (sorry for asking non-specific questions earlier):

I successfully ran

rpm -i fvwm.....rpm

onto my target computer, with the hope that this would install a working instance of fvwm onto that computer, without the need to untar the fvwm…tar.gz file onto that computer.

Then, I updated the $[HOME]/myUser directory with a .xinitrc file and a .Xclients file that both readexec fvwm2 This is all that was necessary to get fvwm to work on my development box, but this does not work on the target computers that I installed the rpm file onto.

Is there a different file that I need to edit because this install is coming from the rpm instead from a tarball?

thanks in advance (seriously, thanks),

I agree with ThomasAdam that you should ask this on a forum mailinglist to solve this, it’s not fvwm-related.

but to help you in some direction, I’ll give some information that might be helpfull.
If you boot your computer and end up with a console login promt, you’ll have to use the startx-command to start fvwm, and the default windowmanager should be fvwm (is in a file in /etc somewhere, I forgot where)

if you boot your computer and end up with a graphical login, it depends on what loginmanager is used. I have no idea what the default windowmanager id in fedora. If it is gnome, the loginmanager is propably gdm, if it is kde, it is more likely to be kdm. Or it is just xdm (which is ugly and only has a username and pasword box). If these windowmanagers don’t offer the option to log in and start fvwm, you’ll probably have to add it yourself. I never did this, so I have no idea where to do this, but I’d guess its in /etc/gdm.conf or something.

you’d be better of if you ask this on a forum that is populated by a lot of fedora users.

as for the missing file, that’s one of the reasons I moved away from rpm. the dependencies are terrible to find out, especially as a newbe.


The login manager stuff has been asked before so you probably want to search on that, the SELinux error you found out yourself, but is obviously due to the use of selinux, which imho creates more problems than it’s worth on a desktop computer.

As a sidenote: xdm doesn’t have to be ugly at all, just search the forums, and especially the Screenshots & configs section for it, xdm is just like Fvwm, ultimately configurable, but ugly (by most people’s standards)by default.

thanks for all your comments. I’ll go see what I can find.

– Skender

If anyone runs into a similar situation while trying to install fvwm onto fedora using rpm, here’s what you do:

update /etc/X11/xdm/Xsession:

exec fvwm2 so when the session begins it starts fvwm up for you.

update /usr/share/switchdesk/Xclients.fvwm:
change exec /usr/X11R6/bin/fvwm2
to exec /usr/bin/fvwm2

other than than, just place your .fvwm2rc into $[HOME]/your_user/.fvwm directory and you should be good to go.

Thanks again to everyone for their help. Looking at the xdm really did the trick.
– Skender