Firefox Problem [ 90% solved ]

Hello everybody,
Im new to these forums. First of all i have to say that e.g. in KDE i have no Problems with anythhing ( who’s wondering hm? ).
But when i try to start my lovely firefox with fvwm, it starts, but never apears.
Its no matter if i use the basic config or stonecrest ones. It just never appears. Thats very strange.

My second problem is, that thumbnailing out of stnecrests config doesnt work for me, i emerged imlib2 and those other things and followed the installation instructions, but if i minimize a window it just disappears and there is no chance to get it back, even not with ALT - TAB.

I will make my own config but for the start i would be happy if stonecrests work. Its just so beautiful.

Thanks for the upcomming help, if you need some more information just let me know, i try to post everything here.

Edit: I forgot to say that with opera or other apps like gaim i dont have this problem, they open normally, but thumbnailing doesnt work for them too.

Have a nice day
Mfg Fabian

[color=red]Edited by theBlackDragon:
–> Moved from Basic questions[/color]

What happens when you run it from the command line when fvwm is running? What does the part of your config look like that launches firefox?

If firefox isn’t working in even the default fvwm config, then it’s not a config problem but a firefox problem. Indeed, try running it from a terminal to see if you get any output. You can also try moving your ~/.mozilla dir and see if that helps, maybe it got corrupt.

As for thumbnailing, do other imlib functions work for the config - i.e. does the wallpaper show up correctly?

If, for some strange reason, there’s a problem with the thumbnail script, do the following. Right-click on any window (gaim, whatever) and click Information. Find the Window ID of the window, something like “0x1200063”. Then, in a terminal, type “~/.fvwm/scripts/thumb “0x1200063” 100 ~/test.png ~/.fvwm/images/icons/gaim48.png”. If it works correctly, a test.png thumbnail should appear in your home dir.

I launch it from console all the time, it shows nothing in the command line, just starts it, my HDD is doing something and the firefox process is available. But is dont see anything :slight_smile:, If i launch it from stonecrests bar its not a difference. Thunderbird has the same problem, only these two apps.

Ok lets look at the thmbnails, there must be a problem with imlib, but i dont know why. I emerged it correctly witout any errors, is dismerged it also and emerged it again but look :

fabian ~ # ~/.fvwm/scripts/thumb "0x1800138" 100 ~/test.png ~/.fvwm/images/icons/gaim48.png /root/.fvwm/scripts/thumb: error while loading shared libraries: cannot open shared object file: No such file or directory

Your wallpaper doesnt show up correctly too, but there was no .fvwm/images/wallpaper.png which it tried to set as my wallpaper, i moved one of my wallpapers there , now the wallpapaer works.

Edit: Maybe the imlib problem has something to do with my amd64 ? Just a thought cause it juses lib64 instead of lib right?

Thanx for your help

Depends how you’re trying to launch it. It might be that if it is from a
menu or key-binding that the actual program name is wrong. You might want
to check that. The other thing is that it might have been told to start
on a different page/desk with SkipMapping, so it won’t be apparent to the
current page/desk you’re on, unless you happened to be on that specific
page/desk to begin with.

You don’t say which thumbnailing method you’re using – but it sounds like
you’re missing EWMHMiniIconOverride support from it.

– Thomas Adam

I’m using stonecrests config, so I use thumbnailing via imlib2.
Sorry but i don’t know many possibilities to do thumbnailing yet.

I launch firefox like opera and gaim from console, so is should start on the same desk, no ? Cause Gaim and opera do this too.

Mfg Fabian

What version of fvwm are you using?

You said to have an amd64, and with fvwm 2.5.12 (or earlier) fvwm fails to catch the map window request, and the firefox window will become orphan, and not show up.

fvwm 2.5.12 compiled on ...

So, should i emerge the masked one ? 2.5.16 ? I’ll give this a try.

UPDATE: Firefox problem is solved, thank you very much :slight_smile:, the newer version of fvwm did it. But now thumbnailing is very important for me, cause now i have to keep evey window up and can’t minimize it :smiley:

Any idea on this ?

Mfg Fabian

The wallpaper is also generated through imlib2 (as well as mpd cover art, the weather icons, and thumbnailing). So yes, none of these are going to work if imlib2 isn’t working properly. I’m not familiar with amd64 but I’d suggest either asking your distro or asking the imlib folks.

@ThomasAdam, yes EWMHMiniIconOverride is set in the config.

Why is that?

Because it disappears and doesn’t show up again?

I had problems with the imlib2 thumbnailing too - I would suggest you to use Taviso’s thumbnailing method at first.

EDIT: I didn’t see that error message that imlib could not be loaded. Maybe try re-merging imlib2? It works fine for me with version imlib2-1.2.0-r2, and I’m on AMD64 too.

I re-merged it several times now, i’ll try to look for a masked one, maybe it helps :confused:

But thanx anyways for your help @all

mfg Fabian

ldd yourImLibScript

This should tell you, if it can find the .so or not.

If it cannot find it, search it, and copy it to /usr/lib.

Or maybe there is,but not:
cd /usr/lib (or where is)
ln -s

Or compile it yourself. … e_id=11130
I think you need imlib2 and the loaders, too.

make install

should do it in the extracted directory.