I’m not entirely sure if I understand the situation but it’s 100% reproducable. If I open certain applications, and then this application opens a sub window, clicking anywhere in the sub window causes the sub window to flicker. I haven’t determined if it’s only the case for modal sub windows or not…

For example: I open leafpad. I then go Options > Fonts, which opens a little font selection window. Clicking anywhere in this font selection window causes the font selection window to flicker. Strangely enough though, this is only the case if the font selection window is on top of the main leafpad window. If I move the font selection window so that part of it is on top of leafpad and part is not, clicking on the window causes a flicker in the font window only where the windows overlap.

I haven’t found this mentioned anywhere else. Can anyone reproduce it? It’s somewhat annoying because I stumble upon it a decent bit. This is with fvwm 2.5.12.

It might be an issue with the way the window is mapped. Are you using transparency? Whenever a window is moved (or to some extent focused – although what I am about to say applies only to moved windows) the window is sent ‘ConfigureNotify’ as an event so that the window knows that something is about to happen to it [1] and that it needs to be redrawn.

What you might therefore want tp try is the following in your config:

BugOpts FlickeringMoveWorkAround True

– Thomas Adam

[1] It’s more complex than this, but it will suffice it to say this is what happens.

Yes, I am using transparency. I’ve actually tried that BugOpts setting already and it hasn’t helped. For what it’s worth, I’m able to reproduce this problem with leafpad’s fonts window, xchat’s preferences window, easytag’s preferences, gthumb’s preferences, etc - quite a few apps. It doesn’t show up in every app though (like firefox, bmp…).

It’s just really weird since it only happens with an app’s sub windows and only when that sub window is overlapping its parent app, not any other app. It’s like fvwm gets initially confused about which app should be raised since they share the same name (or class or resource or whatever it is…).

I’m still having this problem and it makes it difficult to click on items in the subwindows (i.e. opening a file in a gtk app’s open dialog box). It’s really the only thing that is tempting me from not continuing to use fvwm because I run up against it 95% of the time and it’s pretty frustrating. I love fvwm though so hopefully someone can help me figure it out…

If someone can try out my config and see if it happens for them, I’d appreciate it.


do you get any errorlogs?

if they errorlogs don’t say something usefull, I would try to do the following:
I see you load some of the configuration with the Read command.
I would try removing these (comment out). restart and see if it still happens.

If it doesn’t happen anymore, you know it’s most likely caused by one of these configfiles.

if that doesn’t go away by this, I’m not sure what to do. I’d have to see the logs I guess or try it out myself (which I currently don’t have much time for)


Thanks for your advice, Johan. I ended up going through my config line-by-line and commenting things out to see if I could find the culprit. Well, I found it! Apparently the “BugOpts RaiseOverUnmanaged on” was causing this flickering… I think I added it because the adesklets website says to add it if you use adesklets, which I was at the time. But since I don’t use adesklets anymore, I am happily removing this line.

Oh man do I love fvwm, I’m so glad I got this resolved.

Well, it’s in my experience a good way for problem solving if you don’t have a clue what is causing the problem, but know which program/config-file is causing it.
Just go back to the beginning by commenting out parts one-by-one or commenting everyting and then adding lines or blocks again.

enjoy fvwm now :slight_smile: