fullscreen and border issues [solved]

Hi all,

I have been trying to get rid of some fullscreen issues. Using

xpdf -fullscreen file.pdf

still leaves me with a border around the fullscreen window. Same thing with Openoffice Impress in fullscreen mode.

For xpdf I can use

Style Xpdf Notitle, HandleWidth 0

but then I have not border to resize the window in not-fullscreen mode.

For ooimpress not even this worked. I could not find the command to use in “Style COMMAND”. Things listed in

ps ax

did not work.

And there is another thing: I want to get rid of the border of blender completely.

Style blender NoTitle, HandleWidth 0

doesn’t seem to do it.

How can I achieve these two things?
Thanks for any help!

PS: I am using gentoo linux and fvwm-2.5.12 (2.5.14-r1 also has this problem).

You want to add “!Borders, BorderWidth 0” to that style line as well, hence:

Style Xpdf Notitle, HandleWidth 0, !Borders, BorderWidth 0

– Thomas Adam

The syntax is not “Style COMMAND”, it is “Style [WINDOWNAME|CLASSNAME]”.
With FvwmIdent you can get the CLASSNAME of the window, or you just use the Window name as displayed in the titlebar. If it contains spaces, put it in quotes, or use wildcards.

For your interest: For a window manager it is impossible(?) to find out which window belongs to which program. So for window-handling it can only use properties of that specific window, like window id, name, icon name, class name and so on. FvwmIdent will list those properties for you.


Maybe I did not make myself clear, sorry. When I use

Style Xpdf Notitle, HandleWidth 0

together with

xpdf -fullscreen file.pdf

I do have no border. But when I use this style with

xpdf file.pdf

I also do not have one. But I want one (in not-fullscreen-mode), because without a border I cannot resize the window!

When I was still using the openbox wm, the “-fullscreen” option of xpdf took care of removing the border and making the window fullscreen.

In short words: I want xpdf to have borders, but when I use “-fullscreen” I don’t want them. Same thing for Openoffice, which I have not yet tested.

@Pixelbrei: Thanks for that piece of information. I did not know that, but it sound logical :slight_smile:.

I can confirm that blender works without a border at all times now, which is exactely what I wanted (this was standard in openbox). The blender window is called “Blender” with a capital-b, that was the reason.

Then when you run xpdf with ‘-fullscreen’, also add ‘-title specialwindow’ or
somesuch, then you can do:

Style *specialwindow* Borders, Title, Handles

How annoying.

Style matching is case-sensitive.

– Thomas Adam

This solved the issue. Thank you very much! :wink: