FVWM 2.6.1 won't compile

I’m running Slackware 13.1, and I’ve been wanting to upgrade to one of
the newer betas for awhile, so I downloaded version 2.5.31 of fvwm a
couple of weeks ago. Before I got around to compiling it, I saw that
version 2.6.1 is now out, so I downloaded that. I just tried compiling
it, and it won’t compile. The last few lines of output are:

FBidi.c: In function ‘FBidiConvert’:
FBidi.c:53: error: ‘FriBidiParType’ undeclared (first use in this function)
FBidi.c:53: error: (Each undeclared identifier is reported only once
FBidi.c:53: error: for each function it appears in.)
FBidi.c:53: error: expected ‘;’ before ‘pbase_dir’
FBidi.c:95: error: ‘pbase_dir’ undeclared (first use in this function)
FBidi.c:150: warning: implicit declaration of function ‘fribidi_get_bidi_type’
make[2]: *** [FBidi.o] Error 1
make[2]: Leaving directory /tmp/fvwm-2.6.1/libs' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory /tmp/fvwm-2.6.1’
make: *** [all] Error 2

I then tried compiling version 2.5.31, and it compiled just fine. In
comparing the two versions, it appears that both FriBidiParType and
fribidi_get_bidi_type exist only once each in version 2.6.1 and not at
all in version 2.5.31. FriBidiParType was FriBidiCharType in 2.5.31.
Was this an accidental change? As far as the other error, it seems that
pbase_dir was changed to fribidi_get_bidi_type(*visual_unicode_str), but
as I said fribidi_get_bidi_type doesn’t seem to appear anywhere else in
the code.

Changing both of these back to what they were in version 2.5.31 allows it
to compile, but what is the correct fix? Those changes must have been
made for a reason. I haven’t installed the newly compiled version 2.6.1
yet, so I don’t know how it will run. Version 2.5.31 seemed to work for
what little bit I tried it, but there seems to be a bug in the way the
FvwmPager module works. I’ll post more on that once I know I have a
fixed and installable version 2.6.1. Thanks in advance.

Known “problem” – go see this on linuxquestions.org

The minimum version of fribidi is 0.19.2 which is needed.

– Thomas Adam

Thanks for the quick reply. That fixed it. Now, where’s the best place to
post a bug report about the FvwmPager module? None of the forums look like
they’re really appropriate for that kind of thing. I’d just post it here,
but it’s not really related to installation.

Just put it under “General Questions”.

– Thomas Adam

Thanks. I’ll do that.