Fvwm 2D redraw speed


I’m using Fvwm 2.5.12 (Gentoo ebuild) for about a month now. It is very powerfull and I’m quite happy with it, except for an apparently slowness in some 2D redraw operations.

My video board is pretty old (Viper 550 - Nvidia TNT chipset - 16Mb), but this behavior is not shown neither in WindowMaker (my previous WM) nor in KDE (my wife’s desktop).

When I close a window, I can see for a very brief moment a part of the wallpaper (using fvwm-root to set it up, through FvwmBacker module). Transient windows also show this behavior when opening (for instance, a “Find” transient in Firefox or Mozilla).

I tried with no wallpaper at all (grey background), but again I can see a flash of the window being redraw.

Maximizing shows a similar pattern: I can see decorations being draw first, then the window’s contents.

Tried this on a reasonably fast machine with a crappy SiS board. Same thing.

Any guesses?

Thanks a lot in advance, Cantão!

These things are pretty hard to find, unless you know where to look, so from the fvwm manpage:

From the BugOpts section:

If none of these suggestions cover your problem you might want to check out the BugOpts section from the Fvwm manpage. If those can’t help you then either there’s something wrong with your X configuration (you aren’t using xcompmgr are you?) or your video card is just too slow…


Hi tBD (same Black Dragon from Gentoo?)!

Yep, I have ResizeOutline as a default style and the FlickeringMoveWorkaround as well as… Thanks for your quick response!

I’ll check other BugOpts options.

About my video board… It’s strange because, as I’ve mentioned, nothing os these annoying redraws happen on KDE or WindowMaker…

Cheers, Cantão!

Oh, by the way… I guess xcompmgr is some of the extensions from XOrg, right? I’m still on XFree :slight_smile:

Cheers, Cantão!

Yup, same one from Gentoo :wink:

Xcompmgr is known to cause that kind of weird behavior, but yes, it’s only available with X.org.

I’ve seen a couple of discussions on the topic, but I didn’t really read them as they didn’t concern me, I’ve never had the problem you mention (unless with xcompmgr, but that doesn’t count :wink: ). So I guess I can’t really help you… Sorry

But maybe someone else can :slight_smile: