Fvwm and fonts in gtk applications


I am using ubuntu hoary with fvwm 2.5.12 and gnome 2.10

I have some problems with gnome related apprlications like nautilus
In order to get my gnome theme I have to add the following command in
my ~/.fvwm/.fvwm2rc file :

DestroyFunc StartFunction
AddToFunc StartFunction

  • I Exec exec gnome-settings-daemon

Then my gnome theme is used with nautilus for example. But if I
restart once fvwm, the fonts get different!! The same as under gnome
truely speaking!

I don’t know how I can resolved that! (I want to have the fonts as
they look after a restart of fvwm).

Any idea??

Regards, Brice

Try using the gnome-font-properties program while gnome-settings-daemon is running – that should then sort things out next time you restart fvwm with gnome-settings-daemon.

– Thomas Adam

No this doesn’t work!!

For now I found a workaround: I use only fonts that can’t be handle by gnome i.e. helvetica, lucidatypwriter…

But I can’t use one of this font with gkrellm… that sucks!!

Thanks for replying!


What did you expect? gkrellm is not an integral part of fvwm. Go and ask on their mailing-list to see if you can do what you want with it.

– Thomas Adam

You didn’t get it!!!

gkrellm is simply an exemple! if I use fonts like Sans of Sherif in the menu of fvwm I have the same problem!!!


So you have the same problem with Fvwm? How do you define your fonts? Gnome related stuff shouldn’t affect Fvwm in any way, even though it might affect programs running on Fvwm (like as you said gkrellm).


I had the same problem with the font in fvwm and I got it working properly!

gnome-settings-daemon affects the fonts display when you specify them as follows:

Font “Shadow=1 1 SE:xft:Comic Sans MS:size=12”

then to get the fonts displayed correctly just replace “size” by “pixelsize” and you’re done!

for gkrellm that was a bit more tricky as you can’t use this option :slight_smile: the workaround is to add "+ I piperead “sleep 1” "to the Initfunction between the command for gnome-settings-daemon and the one for gkrellm!

Regards, Brice

You could also use the fvwm function “Schedule”, that will save you the overhead of the PipeRead:

+ I Schedule 3000 Exec exec gkrellm


just for completeness of the matter.

In fact gnome-settings-daemon overrides your dpi settings when you use it. The correct settings can be found in /var/log/XFree86 (at least for me). Then the trick is to use gnome-font-manager in which you can give your dpi settings (it uses a to big value by default for me).


This is quite interesting. I actually like the way the fonts look in Gnome but I hate using the gnome-settings-daemon. It makes the fonts nice in fvwm but make my xterms wonky…

So I was wondering if there is a configuration in Xorg/Xfree where you can change the system dpi setting or if it is a per application thing.

You can change it here in this file:


(this is on Debian running XFree86.) It’s a server thing, and not per application.

– Thomas Adam

There might be some interesting info here, I haven’t tried it myself yet and the file ThomasAdam sugested doesn’t exist in an X.org installation…

That is pretty good info too…but I found an other answer in the Gentoo forums post and it is great because you don’t have to change any of the main system files. However it is good to know that if you want to, you have to you can just change the startx script.

By the way, since I use Qingy to log in, I by pass the startx script so It doesn’t get read anyway. I will have to talk to him about that.