Fvwm does not repaint

Computer: HP Zbook G3 with Xeon .
Dist: Fresh Fedora Linux 39 (Workstation Edition)
Fvwm: Fresh install off fvwm3 from github.

No repaaint in either default config or my own which I deiveloped over the years.

Also tried fvwm 2.7 from package manager. Same problem.

Hi @dante65

This has to be a graphics driver problem. Definitely outside the support that we can give here as it’s not a fvwm problem per se.

Hope you resolve it though.

I understood it is not Fvwm to blame.
Thank you to give me a direction to go to solve this.

I just would like to know. Why do I not have that graphic driver issue with other WMs / DEs?

At this system I tested besides of fvwm2,7, fvwm3: fluxbox, xfce, lxde, gnome, mate.

I run OpenBSD 7.5-current with:

inteldrm0 at pci0 dev 2 function 0 “Intel HD Graphics 4600” rev 0x06
drm0 at inteldrm0
inteldrm0: msi, HASWELL, gen 7

I cannot run certain applications like Chromium and the derived programs like Iridium. Also a fair amount of other applications.
These applications reject this particular set of DRM drivers because they don’t support certain functionality. You might have a similar problem. I can solve this problem by adding video hardware that has better drivers.