Fvwm enlarges all other (gtk2) fonts!


I don’t know anymore how I fixed it but after a HDD crash I lost my config and all. But even with no config (the standard ugly shit), when i start xterm (fontsize 10 in .Xdefaults) the fontsize is HUGE. if I adjust it to 8, it’s the same as in xfce4 and gnome2.
Same problem in bluefish editor, gvim and others: all fonts are too big! What the fuck? How can you solve that?

I already installed gtk2-theme-switch and used the font option and the looks & menu fonts are OK right now. But the general text stuff isn’t. I mean, even xterm has fucked up fonts? Help?

Thanks :slight_smile:

BIG FONTS @ FVWM2 : users.skynet.be/klak/fonts_huge.jpg
OK FONTS @ XFCE4 : users.skynet.be/klak/fonts_small.jpg

is there also a way to edit the iconset for gtk2 in fwvm?
No option in gtk2-theme-switch for that…

Solved by starting gnome-settings-daemon
Is there another way? (The iconset still needs to change)

What order are your font lines listed in /etc/X11/XF86Config-4 (or xorg.conf, if you use that)? Also, what is the -dpi option that your Xserver is told to run with? I set my -dpi to 96, and list the *75dpi fonts in my XF86Config-4 file, before the *100pdi fonts.

I don’t see how. GTK is window manager agnostic.

– Thomas Adam

Well, if you have gnome installed gnome-theme-manager will let you select an icontheme, but I suppose you could also put it in your ~/.gtkrc-2

Btw, welcome back Jefklak :slight_smile:

Yeah indeed, damn I need to re-learn all tricsk :wink:

BlackDragon: apoligies if I didn’t moderate the forum for a few months, have been extremely busy with… “general” life 8) But I promise to spend some more time with my favourite WM and forum :slight_smile: