fvwm hangs when loading

Hi :slight_smile:

I’ve run RH/Fedora, with Gnome as my desktop environment, on my laptop’s linux partition for a little while now, but I’d like to try a wm that forces me to interact more with the command line. Therefore, I’ve been trying to get fvwm to be my default wm, and so far, I’ve had no luck. I tried all sorts of things with gdm/xdm, but while fvwm -replace would work from the command line when I was already in Gnome, fvwm would not load. To isolate whether the problem was in my fvwm install (I installed an i386 rpm of 2.4.19 from rpmfind.net) or the way Fedora/gdm was handling X, I set my default runlevel to 3 in /etc/inittab. Then, after I logged in at the text login prompt, I ran startx. My ~/.xinitrc is:


.xinitrc file

exec fvwm[/code]

I was able to login successfully, but then there’s just a blank screen – fvwm seems to hang before it loads.

I’m sorry I can’t include more details, but part of my problem is that I don’t know where startx or fvwm is logging (if at all). I’ve tried looking at the faq and searching the forums, and of course googling, but I can’t find directions on how to check on fvwm’s errors. Any help, even with isolating where to find what the problem is, would be appreciated!



IBM Thinkpad R51
Fedora Core 3

You can captuer Fvwm’s startup messages as per this post.

When you get Fvwm to start properly you might want to have a look at the Fvwm Beginners Guide.

Or check out some of the links in this topic or some of the information from this post.

I fixed it. Well, it turns out I was being incredibly stupid and didn’t realize you had to start the setup menu – I’d assumed it would load some horribly ugly default, (like an old version of fluxbox had done when I tried that on a different linux box), so I was dismayed to be faced with a blank screen.

I know this would only be for very clueless users (like myself, who was nervous enough about fiddling with my own computer, where I could actually break things as opposed to just customizing my login at a linux computer lab, to not think of the obvious ‘click’), but might it be worth mentioning somewhere?

Thanks for the help – I’ll be heading over to that Beginner’s Guide!