[FVWM][main]:<<ERROR>> can't open display [SOLVE

Dell inspiron 5150
ati-drivers Radeon M9

I just moved from xfree to xorg. Prior to the move my fvwm ran fine. I used Suzanne Skinner’s config files with very little modification. At first I had not re emerged xterm and so when I booted up, although it did boot into fvwm just fine, I was not able to do much since I could not spawn a terminal. I then used gentoo live cd to chroot into my environment and I emerged xterm. I also ran env-update and source /etc/profile. I then ran dispatch-conf and updated all my 200 and some config files that needed updating. Rather then re-hasing everything, here is my post on the gentoo forum.

Thank you TheBlackDragon for setting up this forum, I did not even know it existed until just now.

Any guidence in getting my system functional again is very much appreciated.


– EDIT –
I just moved this post from the general fvwm discussion. I did not realize that we were not suppose to ask for support in that thread. Sorry about that.

I just added a ~/.xinit file with the line ‘exec fvwm’. Now from the console I can type startx and fvwm starts no problem. However, fvwm still does not start from boot. I still get the same error message as before.

[color=red]Edited by theBlackDragon:
–> moved from Basic questions[/color]

This is now solved. Apparently xorg 6.8 is not compatible with ati-drivers so I downgraded to xorg 6.7.0-r3. Next I emerged xterm and did an env-update. I also did an opengl-update.

I was also running gensplash and I found out that the radeonfb has some problems:

So I switched to vesa. Everything seems to be working well now.


My pleasure :slight_smile: It didn’t exist until about less than a month ago either (I announced it on the Gentoo boards on the second of november) so keeping that in mind this board is rapidly growing (I think so anyway :wink: ).

Welcome aboard :slight_smile:


I hope that the FVWM guru’s of gentoo come over here to their own board of their favorite windowmanager :slight_smile:

Well, taviso said he’d pop in from time to time, so I suppose he’s been here a couple of times, even though he didn’t register (yet) :slight_smile:

But this is getting pretty off topic, so let’s continue this somewhere else :slight_smile:

ati recently came out with some drivers that are xorg 6.8 compatible. So I am now having this problem again.
.xsession-errors does not tell me anything related to this issue.
Again Everything loads fine until the very end when it tries to startx.

My system setup does not appear to use .xinitrc. I have added it and removed it and it makes no apparent difference. Once I log in using the consol I just type startx and fvwm loads up fine. It just does not want to load up without my help for some reason. Given that my system does not appear to be utilizing the .xinitrc file what other ways can gentoo load a windows manager such as fvwm?


Personally I use entrance as a login manager or I just load Fvwm with startx although gdm and kdm should also work, there’s also qingy which is sort of a displaymanager that runs on DirectFB, and also I came accross this post some time ago.


I have decided to go with the entrance login manager as well. I discovered that I was using kdm before, but this requires kde and I am going to remove that from my system. I am fairly sure that kdm was unmerged when I upgraded my ati-drivers for some reason. Or it also may have been when I upgraded to xorg 6.8. Anyway I have sorted this whole issue out now. Thank you for your input.