I just recently added some animation to my config but I ran into a funny problem. Hopefully you guys can help me out.

Here is what I have :

#Animations :) DestroyModuleConfig FvwmAnimate: * *FvwmAnimate: Effect Turn *FvwmAnimate: Delay 5 *FvwmAnimate: Iterations 30 *FvwmAnimate: Width 1

This works great…sorta.

Anytime I open a new window, or another window opens from inside a program, it doesn’t use the animation effects when minimizing the first time.

For example: When I open firefox for the first time after logging in, I minimize it. It minimizes normally, WITHOUT the animation. If I restore it, it uses the animation, and if I minimize it again, it uses the annimation.

The animations just don’t work initially. Why? And how do I fix this?

It also does it if new windows are spawned from within a program. Say that same firefox window has been running all day and the animations have been working save for the initial time. If I go file>new window … then try to minimize it, it minimizes WITHOUT using the animation effects.

I think they are sweet, but I want all of the windows to animate EVERY time i minimize them.

Any thoughts?

What version of FVWM are you running? I can’t reproduce this in the slightest – and I’m using 2.5.16.

– Thomas Adam

I can reproduce this with 2.5.16.

(Also, I tried FvwmAnimate a long time ago and never really cared for it, but your config right there for it is pretty nice. I’m tempted to keep it in…)

fvwm 2.5.14

Stonecrest, do you think this could ahve something to do with the thumbnailing script we are using (im using the one from your config)?

That’s an interesting thought – essentially, the only time FvwmAnimate wouldn’t animate a window is if it didn’t have an icon associated with it (you can get around it just, by using SendToModule, but it’s a PITA).

– Thomas Adam

Can you explain to me how I use SendToModule?


It IS caused by the thumbnail config we (stonecrest and I) are using. I am trying out the FvwmThumbnail Module now, and the animations work.