FvwmButtons and Swallowing..

Hey guys,
Wasn’t really sure where to post this but here goes:

Since day one that I’ve been using FvwmButtons and swallowing I’ve had a problem. The problem is that whenever something (well most things) is swallowed, my cursor turns into a select cursor, i can moved it around with the keyboard etc, and it wont go away untill i click one time… And this is very annoying at startup because I’m swallowing quite a few things, so i have to atleast click three times before i can use fvwm, and if i don’t click, nothing new will load on the screen either.

I’ve tried some other peoples fvwm configs but the problem doesn’t exist on most, I’ve tried to search for similarities and differences to mine but i can’t find any that would cause it.

Once I even tried another persons config, there wasn’t a problem, so i tried to create fvwmbuttons in my own config and swallow the same appliction, result was select >_<…

Any of you guys had this problem or a solution?
Thanks in advance,

Can you post the relevant part of your config?

That’s just it… What is the relevant part?
ah well I’ll post some settings and fvwmbuttons…

DesktopSize 3x1
SnapAttraction 0
OpaqueMoveSize -1
EdgeScroll 0 0
EdgeResistance 200 100
EdgeThickness 1
ClickTime 300
MoveThreshold 3
HideGeometryWindow Always
SnapGrid 1 1
EwmhBaseStruts 0 0 0 0

ModuleTimeout 10

IgnoreModifiers L25
BugOpts FlickeringMoveWorkaround True

DestroyModuleConfig TaskPanel: *
*TaskPanel: Geometry 410x56-0-0
*TaskPanel: Rows 56
*TaskPanel: Columns 410
*TaskPanel: Colorset 8
*TaskPanel: Frame 0
*TaskPanel: Padding 0 0

*TaskPanel: (2x56, Frame 1)
*TaskPanel: (408x2, Frame 1)
*TaskPanel: (204x54, Swallow(UseOld, SwallowNew) “FvwmPager” “FvwmPager”)
*TaskPanel: (Colorset 9, 74x54, Frame 4, Swallow(UseOld, NoClose, SwallowNew) “Xystray”)
*TaskPanel: (130x54, Swallow(UseOld, SwallowNew) “FvwmClock”
“FvwmScript $[fvwm_script_path]/FvwmClock 8”)[/code]

When the pager and FvwmClock is swallowed the problem exists… however the swallowing the tray doesn’t cause problems

Just your FvwmButtons config. The rest of it is unrelated.

Out of interest, does removing ‘SwallowNew’ from the options for FvwmPager and
FvwmClock above, help?

– Thomas Adam

Unfortunately not, i tried it again just to be sure, but that has never been the problem, before i didn’t use those and i still had the problem.
This problem is nothing recent either :/, been like that for a long time.

EDIT: It’s soo strange… If i use another persons config and there’s no problem… And i copy over the FvwmButtons exactly like in his, and i use the exact same scripts, there’s still a problem when loading my config… >_<

Oh man… now i feel so stupid… I’ve been trying to figure this out for like half a year if not more…

I tried to uncomment all of my configuring (this time including all modules that i load at startup etc) and the problem was actually something I’ve been using from day one. FvwmEvent, i use it to give focus to new windows… >_<…

Well It’s a good thing i posted, I hope this can help someone in need and atleast i finally got my problem solved!!!