FvwmButtons swallowing urxvt cancel character composition

Hi there :smiley:

I have a super tricky bug that I have no idea how to fix.
I want to do a drop down console using urxvt. I’m using an us layout with the variant “international” which help for typing accented characters (example ’ + e = é)
When I launch an urxvt term alone, composition works without any problem.
However swallowing it in an fvwm button remove the composition … worse I cannot even type the character used for it like ’ " ~ ` :confused:
And “fun” if I swallow an xterm it works …

So here’s the code:

# Console quake
DestroyFunc StartConsole
AddtoFunc StartConsole
+ I FvwmButtons ModConsole
+ I Wait ModConsole
#+ I Next (ModConsole) Maximize ewmhiwa 100 50
+ I Next (ModConsole) State 1 True

DestroyModuleConfig ModConsole: *
#*ModConsole: Geometry 1366x384+0-2000
*ModConsole: Geometry 1366x384
*ModConsole: Colorset 11
*ModConsole: Rows 1
*ModConsole: Columns 1
#*ModConsole: BoxSize fixed
*ModConsole: BoxSize smart
*ModConsole: Frame 0
*ModConsole: Padding 0
*ModConsole: ( Swallow "quake" 'Exec exec urxvt +tr -name quake -bc +sb -e bash')

# Fonction qui fait apparaitre / cache la console quake
DestroyFunc ToggleConsole
AddToFunc ToggleConsole
+ I None (ModConsole) StartConsole
#+ I Next (! ModConsole State 1) AnimatedMove 0p 0p ewmhiwa
+ I Next (! ModConsole State 1) AnimatedMove 0p 0p
#+ I TestRc (Match) All (ModConsole) Focus
+ I TestRc (Match) All (ModConsole) WarpToWindow 50 50
#+ I TestRc (NoMatch) All (ModConsole) AnimatedMove 0p -$[vp.height]p ewmhiwa
+ I TestRc (NoMatch) All (ModConsole) AnimatedMove 0p -$[vp.height]p
+ I Next (ModConsole) State 1 toggle

Style ModConsole WindowListSkip, !Borders, BorderWidth 0, !Handles, Sticky, !RoundedCorners, !Title
Key escape A C ToggleConsole

There are some tests around (sorry for the #). I removed my .bashrc .Xdefaults, even recreate from scratch a user …
The best I managed to achieve was to remove geometry everywhere (button/term) then a tiny term of 1 character appear and composing is working :neutral_face:
More weird, ieverything works with the exact same configuration (fvwm/urxvt) on another machine (but the screen is 1280x1024) with same version of fvwm/urxvt/* and same configuration files

I’m surely missing an option or so
Thanks for help

Edit: having fully reinstall the laptop (linux part …) with all basic software, same bug! (trace of install here: arnaud.fortier-family.com/wiki/d … linux/30l3 )

Sounds like the winner is … f%$#@*g systemd !
I managed to reproduce this behavior on my PC at work!
In my ~/.xinitrc:
at work:

exec ck-launch-session fvwm >& .fvwm-log


exec fvwm >& .fvwm-log

-> wiki.archlinux.org/index.php/Xi … he_session

However, characters are not composed at work but I can still use ’ ~ " by double pressing the keys … :smiling_imp:
Amazingly reverting to the original exec ck-… line … no composition anymore anywhere! Super

setxkbmap -print | grep xkb_symbols | awk -F"+" '{print $2}' us(intl) but no composing

I’m really done

Discussing on #rxvt-unicode, I changed the FvwmButtons so it outputs locale into a file … result: correct locale set everywhere (en_US.UTF-8)
I tried with urxvtd/urxvtc same behavior :@

I used FvwmIdent Module to chase differences:
On the quake terminal, it says: - Input Field XWMHints missing
While on a normal one: - Input Field: True

I also realized that I can have accented characters on this “quake” terminal but composing with AltGr (é = AltGr+e)

Any thoughts / ideas?