FvwmMpd (player and playlist editor)

Release of my playlist editor and Hun’s player together, you can get it here.

Changes in this version:

  • changed the shebang to point to the universal location (theBlackDragon)
  • fixed up the move up and down buttons so they now work as you’d expect (Hun)

Enjoy and don’t hesitate to report bugs or request features :slight_smile:

thanks very much for the script BlackDragon. Can I ask for the playlists browser and playlist save options to the script? You can add these two to the
menu under File. These are the only things I am missing in the editor.


is it just me or is there a file with the functions Music-LoadPlaylist and Music-SavePlaylist missing in the tarball?

when I click on the appropriate buttons in the menu of the playlist editor, I get [FVWM][__execute_function]: <<ERROR>> No such command 'Music-LoadPlaylist'
and nothing happens.

all the other things work fine.

I have 12 files in the FvwmMpd-directory. I did a search for files containing these functions (case and non-case sensitive) There doesn’t seem to be a save or load function defined somewhere.

any ideas?


That’s normal, those refer to functions in Fvwm Crystal, I apparently forgot to remove those hooks when I released everything. Anyway, I am planning to implement those natively using FvwmScript and python but that won’t be before half september, after the exams… :frowning:

hehe, know the feeling :confused:

leave it that way, I’ll just use the gmpc playlist editor. I was going to modify the player anyway so I’ll just get rid of the playlist button.


For some reason when I try to load this script on startup, I get the following:

mpd is definitely running though and if I start up gmpc, it connects just fine and works without a hitch. How do I diagnose this problem? Thanks.

Does mpc work from the command line? (eg, just typing ‘mpc’ should give you some stats about volume ed), if this doesn’t work then on what port are you running mpd? It might be that you are running it on a different machine and/or a nonstandard port, setting the environment variables shown above ($MPD_HOST and $MPD_PORT) should fix this issue.

No they don’t… but that doesn’t seem important because mpc’s man pages say that it defaults to localhost:6600 which is what I have mpd set up with. If I look at gmpc’s settings, it also shows localhost/6600 and works. And I can even run ‘mpc play’ and successfully hear music. So I just can’t understand why it’s saying that the connection is refused…

ETA: Nevermind, I found out the problem. The Player script was set up with a WindowPosition that was off my 1024x768 screen, it’s indeed working. Sigh, I should get some sleep.